Jump to content
Videowolff

How to get the grid to strictly appear on an art board.

Recommended Posts

So I have 2 art boards but whenever I want a grid to appear for just one (isometric on one, normal on the 2nd), it just slaps the entire grid over the entire project. How can I get the grid to strictly stay on one specific board? Using the Windows version.

 

image.thumb.png.cb4f59a65adae2c9d7ac7e3d8b998bb8.png

Share this post


Link to post
Share on other sites

I am not sure how it is supposed to work with Windows but with Macs, each artboard can have its own grid. Also, the grid is shown only for the currently selected artboard, not for any others.

So maybe this is a Windows only bug?

Share this post


Link to post
Share on other sites
32 minutes ago, R C-R said:

I am not sure how it is supposed to work with Windows but with Macs, each artboard can have its own grid. Also, the grid is shown only for the currently selected artboard, not for any others.

So maybe this is a Windows only bug?

 

I really hope not. It is really frustrating to work with. 

Share this post


Link to post
Share on other sites
39 minutes ago, R C-R said:

I am not sure how it is supposed to work with Windows but with Macs, each artboard can have its own grid. Also, the grid is shown only for the currently selected artboard, not for any others.

So maybe this is a Windows only bug?

Even on iPad only the active Artboard shows the grid...

And you can have different gridstyles on every separate Artboard...

Share this post


Link to post
Share on other sites
6 minutes ago, ErrkaPetti said:

Even on iPad only the active Artboard shows the grid...

I would expect the iPad version to behave like the Mac desktop version in this respect, but until some Windows user or a moderator can comment on how it should/does behave on that platform, we won't know if this is a Windows only issue or what.

Share this post


Link to post
Share on other sites
8 minutes ago, R C-R said:

I would expect the iPad version to behave like the Mac desktop version in this respect, but until some Windows user or a moderator can comment on how it should/does behave on that platform, we won't know if this is a Windows only issue or what.

I just checked my HP Spectre X360 Win-tablet-laptop with latest Win10 v1909 setup, and both latest retail version of Affinity Designer and latest beta version of Designer show the grid on every created Artboard, and not possible to show different gridsetup en each Artboard...

Share this post


Link to post
Share on other sites

Hi Videowolff :)

Thanks for your report, unfortunately this is a known bug on Windows and is currently with our developers to be fixed - hopefully as soon as possible.

I'll bump the bug report with your thread now, my sincerest apologies for any inconveniences caused in the meantime.

Share this post


Link to post
Share on other sites

I thought this was a feature rather than a bug.
As far as have experienced it, on Windows, Designer displays the grid for the currently selected artboard – as already mentioned, one grid per artboard – but it shows the grid across the whole canvas and therefore the grid looks like it has been applied to other artboards when it hasn’t.
I thought there may have been some good reason for it that I didn’t know about. Glad I'm wrong as it is a bit distracting.

Share this post


Link to post
Share on other sites
13 minutes ago, GarryP said:

As far as have experienced it, on Windows, Designer displays the grid for the currently selected artboard – as already mentioned, one grid per artboard – but it shows the grid across the whole canvas and therefore the grid looks like it has been applied to other artboards when it hasn’t.

But note that in my screenshot, Artboard3 is active, but it and the grid are misaligned, which is not only distracting but unhelpful. I wouldn't mind the grid showing over inactive artboards, if it were at least properly aligned on the artboard that is active :)

Share this post


Link to post
Share on other sites

Oh yeah, I didn’t notice that. That definitely looks wrong to me. I haven’t seen that myself but I’ve had some issues with multiple artboards and grids in the past that I’ve just been able to ‘click my way out of’ so haven’t reported them (irreproducible workflow).

On a similar theme, can anyone give a good reason why it might be better to have the grid visible outside of the currently-selected artboard (as it is now) rather than just inside the artboard? I’m just wondering if there could be a good reason for it to be like that, or not. I think it might be better if it was only visible inside but I’m open to reasonable persuasion otherwise. Up ‘til now it’s been a distraction to me but I might not be using it enough to see the benefit.

Share this post


Link to post
Share on other sites

We have made fixes/improvements to Artboard grid display in the latest Windows customer beta. Sorry this issue has taken so long to get resolved properly. If you would like to try these changes the beta software is available in the forum posts listed below.

The latest beta builds are downloadable from links at the top of each of these beta forum posts.

These betas install parallel, next to the release version (they do not overwrite your release) and so the fixes can be tried in the beta without affecting your normal workflow in the release version. #when using beta builds, please work on copies of your files, as 1.8.0 uses a more advanced version of the file format than 1.7.3

Once these programs have been through a full beta process the change will be released in a future free 1.8.0 update/patch to all customers.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.