Jump to content

Recommended Posts

When working in RAW I apply noise reduction which works quite well.  But when I click 'develop' the noise returns to my image.  Am I missing something?

 

Affinity Photo v 1.3.4

Sony A7s raw photo

Share this post


Link to post
Share on other sites

I have experienced the same problem except in this instance it was with the Nikon NEF raw file format (D7100).

 

Noise reduction would work nicely when working on the raw file but all changes would be discarded when hitting 'develop'. After repeated tries it did eventually work.

Share this post


Link to post
Share on other sites

Hi, I'm having the very same issue. Image is edited in Developer Persona then is 'developed' by clicking the Develop button and the final image is not identical to the original - complete loss of noise reduction.

 

Any help on this matter?

 

Affinity Photo v 1.34

Sony a6000

Share this post


Link to post
Share on other sites

Same for me. Because I need to save the final image only for the web, I did this:

  1. clicked develop (losing noise reduction)
  2. in photo mode/persona resized the document to a width of 1600px
  3. entered again in develop mode
  4. reapplied the noise reduction
  5. clicked develop, and got it

I think for me the problem could be my macbook pro (late 2008), too old probably... by the way very annoying bug.

Share this post


Link to post
Share on other sites

Same today...

I connected AP to my normal "Photos" App. Every application of it works like contrast.. But noise reduction isn't.

 

Please help me! It's an important part of improvement which would be great to use

 

Version 1.4.3 on MacBook Pro 2014

Share this post


Link to post
Share on other sites

got this too i;ve seen it work with small tiffs with my trial version. today i got myself the patched one expecting it to save the luminosity,. it does not 

Share this post


Link to post
Share on other sites

I got the same problem with my Nikon D7000.

The noise reduction is not applied when I click Develop.

 

I'm using Affinity Photo 1.4.3 on MacBook Pro (Retina, 13-inch, Early 2015).

Share this post


Link to post
Share on other sites

Hi all, to expand on a previous post, the preview for the noise reduction is dynamic and alters with zoom level. To see the exact affects you need to view to document at 100% zoom level before applying the reduction. This current implementation is by design, bu I do feel this could be improved somewhat. Feel free to create a thread (or add you thoughts to  current one) in our feature request section to get this improved 


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.