Jump to content

Recommended Posts

Nik Collection just prompted me to install an upgrade to version 2.3.0.0. I am on Affinity Photo 1.7.3 and I want to avoid another disaster like what we experienced about a year ago with Nik just bombing on Affinity Photo. That was only changed when the finger pointing and shoulder shrugging caused a user community sh*t storm. However, I don't have time for the same thing this time around. Can anybody tell me if this is compatible BEFORE I install the upgrade, please? If it is not compatible, when can we expect it to be?

Thanks.

PS. I am on Mac OS Catalina.

Share this post


Link to post
Share on other sites
6 minutes ago, dolunaykiz said:

Thanks for the input. None of the Nik Collection should crash anything IMHO. We've already been through it.

I agree, Dfine 2 should work, the rest of the filters work well and apply the results fast, so they are almost there.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.