Jump to content
RMole

Apple Photo (Catalina 10.15.1) v Affinity editing Still Not Working

Recommended Posts

Hi All at Affinity.

A month ago I posted about Affinity v Catalina not working.

Its still not working

Yet the post has been closed

Can we have some progress please

Share this post


Link to post
Share on other sites

Hi RMole :)

I can confirm that this is still with our development team, unfortunately due to the Catalina release and changes made by Apple this issue has taken longer than usual for us to resolve, my sincerest apologies.

We currently have an internal build where we believe the issue to be fixed, once this has been cleared by our QA team it should be uploaded to the forums as our next beta version for our users to test.

I appreciate this issue has taken longer than we'd hoped to fix, my sincerest apologies for any inconveniences or delays caused by this - rest assured we're working hard to set this right ASAP.

Share this post


Link to post
Share on other sites
On 12/3/2019 at 12:46 PM, Dan C said:

Hi RMole :)

I can confirm that this is still with our development team, unfortunately due to the Catalina release and changes made by Apple this issue has taken longer than usual for us to resolve, my sincerest apologies.

We currently have an internal build where we believe the issue to be fixed, once this has been cleared by our QA team it should be uploaded to the forums as our next beta version for our users to test.

I appreciate this issue has taken longer than we'd hoped to fix, my sincerest apologies for any inconveniences or delays caused by this - rest assured we're working hard to set this right ASAP.

Hi and again I am sorry to contact you but!

Despite an up date by Affinity the conflict between Photo Catalan and Affinity is still not resolved. You did kindly suggest I use the beta version (thanks) but I cant seem to navigate my way to a way of down loading it

Can you kindly assist with a possible time scale on the fix and a way to download the beta version

Kind regards

 

Share this post


Link to post
Share on other sites
1 minute ago, RMole said:

Despite an up date by Affinity the conflict between Photo Catalan and Affinity is still not resolved

I'm sorry to hear you're still having trouble @RMole - could you please open Affinity Photo > About and let me know what version number is shown here?

Did you at any point install the Photo Beta from the forums?

Share this post


Link to post
Share on other sites
1 minute ago, Dan C said:

The below is taken from a direct message - 

I'm sorry to hear you're still having trouble @RMole - could you please open Affinity Photo > About and let me know what version number is shown here?

Did you at any point install the Photo Beta from the forums?

Hi, many thanks

Version 1.8.1 and no I didnt (I think our posts are crossing, I will wait for you to take the lead)

 

Share this post


Link to post
Share on other sites

Thanks for letting me know - what is happening when you're running the 'Edit With' extension from Apple Photos?

Is this the same error you've been seeing previously, or a new error? (a screenshot of any error message would be helpful here)

Does this happen with every image, or only certain ones?

Since the update this issue has been marked as fixed, as all of our test machines now work as expected and this was also resolved for other users when updating to version 1.8 - so the issue you're having is likely system specific.

Share this post


Link to post
Share on other sites
11 minutes ago, Dan C said:

Thanks for letting me know - what is happening when you're running the 'Edit With' extension from Apple Photos?

Is this the same error you've been seeing previously, or a new error? (a screenshot of any error message would be helpful here)

Does this happen with every image, or only certain ones?

Since the update this issue has been marked as fixed, as all of our test machines now work as expected and this was also resolved for other users when updating to version 1.8 - so the issue you're having is likely system specific.

Hi

Sorry for the delay. The final screen is this

image.png.0fbfa3581af93324fc05568e3335665f.png

 

It happens with images taken with my iPhone 11 pro (latest upgrade) Fuji X100-F (latest upgrade)

The process I follow is

Open image in Photo > Edit > Edit with Affinity

Conduct the edit wit Affinity > Save> Close> Go to Photo > save changes then the attached image is displayed

Share this post


Link to post
Share on other sites

No problem at all, my apologies for not responding here sooner Robert.

I've downloaded a sample RAW file from the Fuji X100-F and followed your workflow, and thus far all developments/edits have been saved back to Apple Photos, without an error message.

Could you please confirm for me, what sort of edits are you making in Affinity? Are you adding multiple layers/adjustments to the image?

Please open Apple System Preferences, then Extensions. Here you should see a list of all the Affinity options, as well as beta options if you have this installed.

Please uncheck all of the Affinity Extensions shown here, then restart your Mac. Navigate back to this dialog and check all of the Affinity Photo options, ensuring to leave the beta options off (should they be present).

Now, try editing your image again - are the changes now saved back to Photos for you?

Share this post


Link to post
Share on other sites
21 hours ago, Dan C said:

No problem at all, my apologies for not responding here sooner Robert.

I've downloaded a sample RAW file from the Fuji X100-F and followed your workflow, and thus far all developments/edits have been saved back to Apple Photos, without an error message.

Could you please confirm for me, what sort of edits are you making in Affinity? Are you adding multiple layers/adjustments to the image?

Please open Apple System Preferences, then Extensions. Here you should see a list of all the Affinity options, as well as beta options if you have this installed.

Please uncheck all of the Affinity Extensions shown here, then restart your Mac. Navigate back to this dialog and check all of the Affinity Photo options, ensuring to leave the beta options off (should they be present).

Now, try editing your image again - are the changes now saved back to Photos for you?

Hi and many thanks for your time on this issue.

So, I, as per your request did the extensions / restart etc

Then:

Shot in RAW
Removed card from camera and dragged file into Affinity and edited

fine and dandy

Ditto
JPEG

Then I “share” the edited image with Photo

BUT

If i then seek to perform further editing of the image by the process Edit> Edit with Affinity
Conduct edit
Whilst in affinity
Save> Close
Then at Photo save change I get the fault banner as before.

If I use the WiFi transfer facility from camera to Photo album I still cant ultimately edit the image

I have done this with both my cameras (XT-3 and now X100 V)

I have conducted the same process on my iMac (High Sierra 10.13.6) and what ever combination I adopt i am able to conduct my editing successfully

Are you able to do a PC share, jump onto my lap top and see if you can replicate m problem ??

Kind regards

Bob M

Share this post


Link to post
Share on other sites

Thanks for your workflow provided Bob - I've been able to replicate this here. Interestingly enough it works correctly with my Canon RAW files, but not with a RAW file from the X T-3, so it may be camera file format specific.

I'm getting this logged with our developers now as a new issue and we hope to have this resolved as soon as possible, many thanks!

Share this post


Link to post
Share on other sites

Any updates on when Affinity will work with OS Catalina on a Mac?  Thank you.  Hesitant to purchase if not working yet. Hope it will soon.  Thank you.

Share this post


Link to post
Share on other sites
1 hour ago, Dan C said:

Affinity is fully compatible with Mac OS Catalina

The problem with Apple Photos for me and many Posting in threads is not fully compatible.


Cecil 

iMac Retina 5K, 27”, 2019. 3.6 GHz Intel Core 9, 40 GB Memory DDR4, Radeon Pro 580X 8 GB, macOS 10.5.4 iPad Pro iPadOS

 

Continuous improvement is better than delayed perfection 

Share this post


Link to post
Share on other sites
20 hours ago, Dan C said:

@bobbiwine Affinity is fully compatible with Mac OS Catalina and the issue regarding Apple Photos has been fixed 

This statement is contradicted in several threads, with issues acknowledged by other AP staff. The Edit in Affinity Photo extension has several major issues requiring work around for some users. Affinity Develop does not, for some users, work with raw photos. Discouraging to read that some AP staff apparently believe the issues with Apple Photos have been fixed while other staff members have acknowledged in other threads that there are problems with Apple Photos that the dev team is trying to fix. 

Share this post


Link to post
Share on other sites
23 hours ago, Cecil said:

The problem with Apple Photos for me and many Posting in threads is not fully compatible.

14 hours ago, rhmb said:

This statement is contradicted in several threads, with issues acknowledged by other AP staff.

I'm sorry to hear you feel this way, 'compatibility' can be a somewhat loose term which many users will interpret differently. The application is technically (ie computationally) compatible with Mac OS Catalina, it can be downloaded, installed and can be used as a standalone app, however as with any app, on any platform, there are bound to be bugs in the software and we are as transparent about these as possible here at Serif.

14 hours ago, rhmb said:

Discouraging to read that some AP staff apparently believe the issues with Apple Photos have been fixed while other staff members have acknowledged in other threads that there are problems with Apple Photos that the dev team is trying to fix. 

We are aware that certain users are experiencing issues with Apple Photos integration, and allow me to apologise if this is the case for you. A recent update unfortunately broke this functionality for all users, and our developers have been hard at work attempting to fix this. A subsequent update has repaired this functionality for many users, including myself, and the internal JIRA log (where we keep all of our bug reports) was marked as fixed because of this, therefore this was the information I had to convey.

I agree there may be other issues at play here, and I do not believe I made any statement otherwise. There are still bugs for some users with this functionality - but that does not mean the application is incompatible with the OS.

Certain users cannot develop images, certain workflows from other external apps into Photos and then back out to Affinity are also known issues - and these are still being looked and and worked on by our developers. As much as the above issue has been marked as fixed, I am aware there are still outlier cases and we are doing our best to help fix this for yourselves and other members of our community.

We're unsure as to the exact reason that this can happen for some customers and not for others, as there does not appear to be a common factor here. Unfortunately this makes tracking down the bug(s) a much more difficult and harder process, as well as this functionality using Apples API which is constantly changing, so we have to also converse with Apple to try and resolve these cases.

Share this post


Link to post
Share on other sites
1 hour ago, Dan C said:

 A subsequent update has repaired this functionality

A official Affinity Photo tutorial may ensure we are all on one page, using the same processes to process Apple Photos in and out of AP., correct extension, etc.  I for one may be doing something completely wrong and would appreciate the official Affinity process.  I do appreciate, in this time of world uncertainty, that this may not be high priority fix. Thank you and stay safe.

 

 

 

 


Cecil 

iMac Retina 5K, 27”, 2019. 3.6 GHz Intel Core 9, 40 GB Memory DDR4, Radeon Pro 580X 8 GB, macOS 10.5.4 iPad Pro iPadOS

 

Continuous improvement is better than delayed perfection 

Share this post


Link to post
Share on other sites
6 hours ago, Dan C said:

I'm sorry to hear you feel this way, 'compatibility' can be a somewhat loose term which many users will interpret differently

My apologies if my comment implied that Affinity was not at all compatible with Catalina. As a user, I was referring to the challenges some have had when using Affinity with Apple Photos, not to the overall compatibility of Affinity with the Mac OS. 

I may also have interpreted too broadly your statement that the issue with Apple Photo was fixed. Obviously you were referring to one set of issues (or just one issue); I was referring to others. It is encouraging to hear that these are being worked on. 

And on a positive note, I confirm that I have had no problems to date using Affinity both as a stand alone and in conjunction with my main photo management and editing app (which is not Apple Photo) on a Catalina Mac. 

Share this post


Link to post
Share on other sites
4 hours ago, Cecil said:

A official Affinity Photo tutorial may ensure we are all on one page, using the same processes to process Apple Photos in and out of AP., correct extension, etc. 

That might help but it would not ensure that everyone is on the same page. For one thing, there are several different ways Apple Photos can be configured, like using different (or none) of its iCloud options, using a System Photo Library located somewhere other than in the default Pictures folder, or maybe disabling the option to copy items to the Photos Library so some are left in their original locations as "referenced photos" & others are in the  Photos Library.photoslibrary.

The Apple system library overview guide topic (& a few others like this one) include the following warning that a lot of users probably have never seen:

Quote

WARNING: To avoid accidentally deleting or corrupting a Photos library, do not alter the contents of a library in the Finder.

It is possible some users have done this (& it is too easy to do the equivalent in AP if accessing a file from the "Open Recents" menu item & the sidebar media Photos was recently used to open a photo directly from the Photos library) so for some their problems with using the Apple Photos "Edit in Affinity Photo" option may be caused in part or in whole by a partially corrupted Photos library.

For some users repairing the library may eliminate the problem; for others it probably will have no effect.

Yet another difference could be that some users have installed a third party add-on that in some way interferes with passing photos to AP or back to Apple Photos via the extension, or there is some minor corruption of some obscure component of the OS itself that does the same thing.

In short, even if everyone uses exactly the same processes as in an official video tutorial, there are a lot of different 'pages' different users could be on.


Affinity Photo 1.8.3, Affinity Designer 1.8.3, Affinity Publisher 1.8.3; macOS Mojave 10.14.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 
1.8.3.180 & Affinity Designer 1.8.3.2 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.3.1

Share this post


Link to post
Share on other sites

@R C-R all valid points.  I still think a basic, Apple Photos, Edit In, Edit With, and actions required to save, share or export would be beneficial.  The tutorial could also instruct user on some of your points, AP, Apple Photos and iCloud requirements.  I do understand the serious nature the world is facing and this is not one of them.  I understand that this is macOS Problem and tutorials are focus on all platforms. Be safe.


Cecil 

iMac Retina 5K, 27”, 2019. 3.6 GHz Intel Core 9, 40 GB Memory DDR4, Radeon Pro 580X 8 GB, macOS 10.5.4 iPad Pro iPadOS

 

Continuous improvement is better than delayed perfection 

Share this post


Link to post
Share on other sites
9 minutes ago, Cecil said:

The tutorial could also instruct user on some of your points, AP, Apple Photos and iCloud requirements.

I think it would be difficult to do that because there are so many possibilities to cover, but like I said it still might be helpful for eliminating a few of them.


Affinity Photo 1.8.3, Affinity Designer 1.8.3, Affinity Publisher 1.8.3; macOS Mojave 10.14.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 
1.8.3.180 & Affinity Designer 1.8.3.2 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.3.1

Share this post


Link to post
Share on other sites
On 3/18/2020 at 2:28 PM, Dan C said:

Thanks for your workflow provided Bob - I've been able to replicate this here. Interestingly enough it works correctly with my Canon RAW files, but not with a RAW file from the X T-3, so it may be camera file format specific.

I'm getting this logged with our developers now as a new issue and we hope to have this resolved as soon as possible, many thanks!

Hi and I note that Affinity has another upgrade. Regrettably the issue I 1st reported is still not resolved

 

Same work flow on my iMac (High Sierra) no problems, never has been

 

Mac Book air catalina still refuses to complete edit even using an image taken after update. 

 

Does / would someone from management like to take control of my Mac Air so you can

 

Watch what I am doing

or

Do it yourselves on y machine

 

I would be so very happy for this to happen (even if shows what a total d*ck head I might well be)

 

Kind regards

 

Share this post


Link to post
Share on other sites

Unfortunately your specific issue has not been yet marked as fixed Bob, my sincerest apologies.

Our developers are aware of this issue, as well as the larger, over-arching issues that a select group of users are experiencing with Apple Photos and we're working hard to resolve this for both yourself and our other customers.

I believe your specific workflow is likely what's causing this for you, there's nothing inherently 'wrong' with the workflow at all, simply this is where the bug lies which we hope to resolve shortly :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.