Jump to content
hi_jp

Affinity Designer(1.7.3) can't type Japanese texts on Catalina(10.15.1).

Recommended Posts

Hi hi_jp,

Welcome to Affinity Forums!
Can you get a screen recording (showing the whole screen) as an example of the problem you are getting. When reporting issues to us it is most helpful to include as much detail as possible. If you struggle to describe the problem then videos are VERY helpful!

https://support.apple.com/HT208721#quicktime

Google Translate:
 

こんにちはhi_jp、

アフィニティフォーラムへようこそ!
発生している問題の例として、画面記録(画面全体を表示)を取得できますか。 問題を報告するときは、できるだけ詳細を含めることが最も役立ちます。 問題の説明に苦労している場合、ビデオは非常に役立ちます!

https://support.apple.com/HT208721#quicktime

Share this post


Link to post
Share on other sites

Hi, Sean P

Thanks for reply.

I recorded screen on Catalina while using Affinity Designer.

I typed "テスト" in Mac's keyboards, but it became "tesuto".

Mac has 2 typed keyboards for Japanese users.

One is US keyboards, Other is JIS keyboards. Japanese users mainly use JIS keyboards.

I hope Affinity team fixes it as soon as possible..

- hi_jp

Share this post


Link to post
Share on other sites

Hi hi_jp,

Thanks for the video, however you've unfortunately cut off the top of the screen that shows the language bar so I can't see exactly what keyboard input and settings you're using. I've tried it on my machine using Catalina and the Katakana input and that seems to be working. If you're using a different setup, would you mind recording a video just showing the settings and setup you're using please? I'm not sure if that was because I was using Romaji to Katakana conversion (I believe that's what I'm using) - I couldn't find a way to get the keyboard to input Katakana characters directly. See my attached video - I used the Shift+Kana to switch from Romaji to Katakana.

I was also using this keyboard:
JISKeyboard.png

Share this post


Link to post
Share on other sites

Hi, Sean P.

Thanks for reply.

I might find the bug..

The image you posted is JIS Keyboard which is for Japanese users.

There are two keys "英数" and "かな" at the bottom of your keyboard.

Both "英数" and "かな" keys exist to switch languages. This doesn't work to switch in Affinity Designer(1.7.3) on Catalina(10.15.1).

But, I was finally able to change language at top of screen, but Japanese users do change with "英数" key and "かな" key because it can be easy to change.

Please fix it!

thanks.

- hi_jp1242762650_.thumb.jpg.694b092269ac057b0d7592ccba46a66f.jpg

Share this post


Link to post
Share on other sites

Hi,

I have just called Apple Support about this problem.

Apple Staff told me I try to make other Mac account and made other account. Then I tested to switch to Japanese from English with "かな" key, but language has not changed.

I have a question. Is your macOS is Catalina 10.15.1??? I think older Catalina worked to switch languages with "かな" key.

- hi_jp

Share this post


Link to post
Share on other sites
2 minutes ago, hi_jp said:

Hi,

I have just called Apple Support about this problem.

Apple Staff told me I try to make other Mac account and made other account. Then I tested to switch to Japanese from English with "かな" key, but language has not changed.

I have a question. Is your macOS is Catalina 10.15.1??? I think older Catalina worked to switch languages with "かな" key.

- hi_jp

That's very strange! Mine is indeed 10.15.1 - have you tried it in any other applications such as Pages, Safari etc?

Share this post


Link to post
Share on other sites

Hi,

If I push "かな" key and "英数" key, space is entered by both keys.

Mac is 2019 MacBook Pro 13". "かな" key and "英数" key of MacBook's keys work in other applications.

- hi_jp

Edited by hi_jp
typo

Share this post


Link to post
Share on other sites

Hi hi_jp,

Sorry for the belated response. This has been raised by another user recently, and I was still unable to reproduce it. However they've found that if 'Romaji' is unticked in the Japanese layout then the problem arises. Due to the current situation I have only just been able to get access to a JIS keyboard where I can now confirm I have reproduced this behaviour so I will get it passed on to development to investigate.

See the post here for full information:

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.