Jump to content
vfxwolf

PDF render garbled text

Recommended Posts

The PDF export in 1.73 seems to be buggered.  Page renders fine onscreen, PDF export fills the document with strange symbols.  Print to PDF  works fine.  Document is sensitive, so can't post screen grabs here, but would be happy to send to tech support

Share this post


Link to post
Share on other sites

Also just noticed this. Doesn't happen all the time. For me it's specifically Crimson Text, Roman that goes all gobbledegook. Italics, Semibold, Semibold Italic, Bold, and Bold Italic all work fine. Just tried to create a test file to upload and it worked completely fine. Same font.

Screen Shot 2019-12-02 at 5.46.47 PM.png

Share this post


Link to post
Share on other sites
1 hour ago, LibreTraining said:

Crimson Text has problems with how the name fields are configured.
Everything is in the style group fields and the Typographic Family fields are empty.
Style groups should only have: Regular, Italic, Bold, Bold Italic
Crimson Text also has Roman, Semibold, Semibold Italic in there.
This is confusing APub and causing font corruption.
It also confuses the heck out of LibreOffice.
So I made a version with fixed names which works properly in LibreOffice - Crimson Text LO
Just tested and it also works properly in APub 1.8 beta.
I left "Roman" in the Typographic Style field where is is OK.

Crimson.Text.LO.(fixed.names).7z

Try those fonts.
My guess is that will solve your issue.

 

Interesting. Will give it a try. Although, as in my screen grab above Crimson Text works fine in one document, and not in the other.

Share this post


Link to post
Share on other sites
On 12/19/2019 at 4:35 AM, Pauls said:

Some people have been getting problems when they have duplicate fonts installed - maybe you have 2 versions of the problematic font ?

This error has popped up again. Different font (Vollkorn). The font is working in the first row of the table. Fails in the paragraph, and the second column. It also displays correctly in the first column, however it has decided to reduce all the numbers by 1, so instead of that column going from 1-8, it now goes 0-7. It also no longer works in a file that it once worked in. Happy to send you some files as well. It also works when I export to all the other file formats.

Screen Shot 2020-01-21 at 9.40.08 AM.png

Share this post


Link to post
Share on other sites
16 minutes ago, Pauls said:

is that from Google Fonts or somewhere else?

You can upload files to the original location

Yeah, I think it's from Google Fonts. Possibly Font Squirrel. I actually resolved it. I'm not sure why but there were multiple installed copies, only one was active (the OTF version). I reactivated all versions, then cleaned up the "multiple versions" error and now everything works as expected.

Maybe Publisher is trying to use TTF files, and it craps out because they're disabled? No idea. But reseting the active/inactive/multiple versions states of fonts fixes it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.