Jump to content
Lagarto

Bug in Color Picker Tool when using transparencies?

Recommended Posts

See attached Publisher document.

1) Select the gray transparent rectangle (it has K100 applied, and layer opacity of 55%).

2) Select the Color Picker tool from the toolbox.

3) Click on the selected gray rectangle. Its color assingment changed to K55, while transparency setting is retained as 55%, accordingly the vsiual outlook of the object being changed.

Can this be intended behavior? The feature picks now the color of a transparent object against the background (at the point where color picker is clicked), which in this case is K55, as the layer transparency of 55% combined with the fill color K100 produces K55, but then applies the color to the object itself without removing its transparency.

If this feature is intended to mimick the Eye Dropper tool of InDesign, it does not behave like this. It applies the selected object e.g. the color assignment of the fill, AND if the object has an opacity setting, it will be copied as an opacity attribute to the selected object, as well.

eyedropper.afpub

Share this post


Link to post
Share on other sites

Hi @Lagarto

This is the intended behaviour. The colour picker samples the colour of what you see on screen (basically a raster preview of the document). If that rectangle looks gray, it will sample gray, and not black. 

Share this post


Link to post
Share on other sites
2 minutes ago, Gabe said:

The colour picker samples the colour of what you see on screen (basically a raster preview of the document).

Ok, thanks. I hope it sometimes changes to behave similarly as in InDesign so that it transfers color and transparency  as separate attributes so that the target object will actually get the outlook of the sampled object. 

Share this post


Link to post
Share on other sites

I suggest you create a new post in the feature requests section, as what you're looking for is a "style picker" and not a colour picker. You can do what you want by copying one object and then just pasting the style as a workaround. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.