Jump to content
Big_Stan

Help needed with Topaz Plugins

Recommended Posts

Getting help from Topaz Labs is liking talking to a wall. They brought in a new operations manager, Eric Lowery, and he made encouraging words about cleaning up the mess, but I am seeing no improvement in their responsiveness.  I send them emails requesting help and I receive an automated reply acknowledging that they received my request, but it takes a week before I receive an answer to my question. And, if their answer doesn't solve my problem, it takes another week (if I am lucky) and so forth. I have a chain of emails going back to 8 October (before Catalina) trying to resolve the plugin problem.  

I loaded their AI plugins into Affinity Photo and they show up under Filters > Plugins, but when I try to use them nothing happens; they don't even start-up.  They do work as stand alone but not as Affinity plugins. And, yes I did restart Affinity Photo.  I am using Mac OS 10.15.1 and AP 1.7.3 on a 2019 iMac and I have the latest versions of the plugins.

1351565702_ScreenShot2019-11-05at3_36_50PM.thumb.png.43b7702304bf3c9744e348b3d1fa10e6.png

 

Share this post


Link to post
Share on other sites

Well PS Plug-ins that have so far not gone through Apple's notarization process will probably make problems under Catalina. I could imagine that it's due to Mac OS Catalinas stricter security changes here, especially if Adobe software has the same problems then.

Share this post


Link to post
Share on other sites

Have it all running flawlessly in Mojave 10.14.6 and think it must be a Catalina issue! 

That's why I wait with updating!

I've been working all day with Adjust AI, Sharpen AI and DeNoise AI in Affinity Photo.

I am beta tester for Mask AI and can confirm that it also works in Mojave and Affinity Photo too.

Share this post


Link to post
Share on other sites

Thank you, however my issue started before Catalina, while I was still using Mojave.  

BTW, all of my other apps are working flawlessly with Catalina.  Going to Catalina was easier than going to Mojave.

 

Share this post


Link to post
Share on other sites

Did you try a total remove of the Topaz apps, a reboot and then clean install of each app?

And  reconnection in the Affinity Photo preferences if necessary? 

They will stay authorized!

Try one to test. But reboot before clean install is important!

Share this post


Link to post
Share on other sites

2065237599_ScreenShot2019-11-06at9_27_37AM.thumb.png.067e58ce0e069d630e94b30f05e0c831.png

DWright, Here is my Preferences window

Media Lab, When I went to my new iMac with Catalina, I performed a reboot and a clean install of each plugin. The Topaz apps are working with no problem as stand-alone.

I am obviously doing something wrong and I cannot figure what it is.

Share this post


Link to post
Share on other sites

Just to be sure that you use the proper paths in Affinity Photo I posted a screen shot for you!
Example:
/Applications/Topaz Sharpen AI/Topaz Sharpen AI.app/Contents/
You can add the path in the “Plugin Search Folder” by clicking “add” the panel opens and you have to do CMD + Shift + G now you can fill in the path etc. Don't forget to click "Authorise Global" and see if the / slash appears in the Plugin Support Folders Panel.

It is possible that you have to click ones on "add" under the "Plugin Support Folders" panel and then activate "Authorise Global".

Restart Affinity Photo.


Regards,

David

Share this post


Link to post
Share on other sites
2 minutes ago, v_kyr said:

See also: https://help.topazlabs.com/hc/en-us/articles/360001129351-Serif-Affinity-Photo-Using-Your-Topaz-Labs-Plug-ins especially Step 3 + 4  there. You have to point to the Topaz tools folders.

Tried that tutorial in the past but it did not work! When you do as I pointed out you get the proper paths!

Share this post


Link to post
Share on other sites
6 minutes ago, All Media Lab said:

Tried that tutorial in the past but it did not work! When you do as I pointed out you get the proper paths!

Since the Topaz tools are individual apps you have to point to every of their apps folder. Thus they probably say here ...

Quote

Mac: Follow the path shown and choose your desired program folders individually

Their images there are just for Win so maybe slighly confusing for Mac users.

Share this post


Link to post
Share on other sites
2 minutes ago, v_kyr said:

Since the Topaz tools are individual apps you have to point to every of their apps folder. Thus they probably say here ...

When you read my post that's exactly what I'm instructing him to do, but then in a way that works on a Mac! That tutorial is obsolete and has to be renewed by Topaz staff. 

Share this post


Link to post
Share on other sites

Did you click "Authorise Global", because it needs to look grayed out  and only a / (slash) should appear in the "Plugin Support Folders" panel.

First "remove" the path, then  Authorize global, then add the path like this: /Applications/Topaz Adjust AI/Topaz Adjust AI.app/Contents/

Just copy and past my path.

You can add the path in the “Plugin Search Folder” by clicking “add” the panel opens and you have to do CMD + Shift + G now you can fill in the path etc.

 

Share this post


Link to post
Share on other sites

To get the slash in:

a.) Affinity Photo -> Preferences -> Photoshop Plugins.

b.) Plugin Support Folders -> Add

c.) Shift+Cmd+G to bring up "Go to the folder" text input.

d.) Type "/" (in other words, root, everything). Press "Ok" a few times.

e.) Photo should show just "/" in the plugin support list.

(only / of course)

Click Authorise Global

But then remove the wrong path and put the proper in the way I explained before:

/Applications/Topaz Adjust AI/Topaz Adjust AI.app/Contents/

Restart the application

Share this post


Link to post
Share on other sites

You are great!! Thank you very much.

I did not realize that "Authorise Global" was supposed to be grayed out. 

I have tried everything that I can think of, but I cannot get "/contents/" to attach at the end.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.