Jump to content

Recommended Posts

54 minutes ago, DWright said:

I have raised this issue with our QA team as this issue is only happening with the Mac version

Doesn't this have something to do with either with the language set in Affinity Preferences > General, or possibly System Preferences > Languages & Regions (or both)?

I ask because with the Affinity Preferences > General set to "English (United States)" & with "English (U.S.)" set as the primary language in System Preferences, these are my only choices:

170753681_spellcheckstylechoices.jpg.1143fda06fba81f23d83e501244fa5fa.jpg

Affinity Photo 1.9.3, Affinity Designer 1.9.3, Affinity Publisher 1.9.3;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.92.236 & Affinity Designer 1.9.2 (showing 1.9.9) for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 14.4 (18D52)

Link to post
Share on other sites
12 minutes ago, R C-R said:

Doesn't this have something to do with either with the language set in Affinity Preferences > General, or possibly System Preferences > Languages & Regions (or both)?

I ask because with the Affinity Preferences > General set to "English (United States)" & with "English (U.S.)" set as the primary language in System Preferences, these are my only choices:

170753681_spellcheckstylechoices.jpg.1143fda06fba81f23d83e501244fa5fa.jpg

I think the OS version is important too, I use English (Canadian) in the OS and have no other language chosen in the OS System preferences but have a much larger list available. This is on 10.12.6 while you are on 10.13.6

1658134966_ScreenShot2019-11-06at6_26_56AM.png.35dd7dd5417edb075c87966e37df7d64.png

MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.6

Affinity Designer 1.9.3 | Affinity Photo 1.9.3 | Affinity Publisher 1.9.3 | Beta versions as they appear.

Link to post
Share on other sites
7 minutes ago, DWright said:

The Mac shows the dictionaries in the native language so yo have English US you will have to change the Mac OS language.

Do you mean in Affinity's preferences or in System Preferences? 

Affinity Photo 1.9.3, Affinity Designer 1.9.3, Affinity Publisher 1.9.3;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.92.236 & Affinity Designer 1.9.2 (showing 1.9.9) for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 14.4 (18D52)

Link to post
Share on other sites
21 minutes ago, DWright said:

Hi @R C-R,

It is the Mac system preferences

There must be more to it than that because even if (for example) I set the primary language in System Preferences to Canadian like @Old Bruce did, I still get the same short 4 item list as before, not the much longer one he did.

Affinity Photo 1.9.3, Affinity Designer 1.9.3, Affinity Publisher 1.9.3;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.92.236 & Affinity Designer 1.9.2 (showing 1.9.9) for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 14.4 (18D52)

Link to post
Share on other sites
54 minutes ago, R C-R said:

There must be more to it than that because even if (for example) I set the primary language in System Preferences to Canadian like @Old Bruce did, I still get the same short 4 item list as before, not the much longer one he did.

Okay I am flummoxed, I have my language set in all the various Publisher Preferences to the same, English Canada. The list I have for choosing in the Publisher Preferences is the same as the Text Styles Language dropdown. I run a lean system and I rarely change from default settings for 99% of the applications I use. There are only the dictionaries from the OS, there have only ever been the dictionaries from the OS and no third party utilities aside from an Audio driver, the Wacom stuff and a Monitor utility.

MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.6

Affinity Designer 1.9.3 | Affinity Photo 1.9.3 | Affinity Publisher 1.9.3 | Beta versions as they appear.

Link to post
Share on other sites

So now we have three different behaviors: my 4 item list, Bruce's 16 item one, & big mile's one shown in the OP.

Hopefully, the QA team can figure out why this is happening & if there is anything we can do so all of us see the same thing.

Affinity Photo 1.9.3, Affinity Designer 1.9.3, Affinity Publisher 1.9.3;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.92.236 & Affinity Designer 1.9.2 (showing 1.9.9) for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 14.4 (18D52)

Link to post
Share on other sites
  • 2 weeks later...
  • 2 months later...
On 11/6/2019 at 3:55 PM, DWright said:

Hi @R C-R,

It is the Mac system preferences

On my Mac my 3 Preferred Languages are set as: English US, French and Italian, and my main language is set as English US.. I still get that same issue of having only English (United Kingdom) accessible for spelling in Publisher when it comes to English.

However if I change my Region (under Language & Region) from Switzerland.. to United States, then in Publisher my choice for spelling changes from English (United Kingdom) to English (without any further mention next to it..).

Of course I will not keep my Region set to United States as I want my temperature, units etc to match my culture.. at the Mac System level..

 

 

Link to post
Share on other sites
  • 1 month later...
  • Moderators

Hi big smile,
Go to System Preferences > Keyboard section, Text tab (on top), click the Spelling dropdown on the right and select the last option Set Up.... Add/tick U.S. English  and press Done. Restart Affinity Publisher. A new English option should appear in the Language dropdown now. It has no locale/region specified - i mean it appears just as English in the list - but should work correctly: it's US English (the missing locale issue was already logged).

Link to post
Share on other sites
6 minutes ago, MEB said:

Hi big smile,
Go to System Preferences > Keyboard section, Text tab (on top), click the Spelling dropdown on the right and select the last option Set Up.... Add/tick U.S. English  and press Done. Restart Affinity Publisher. A new English option should appear in the Language dropdown now. It has no locale/region specified - i mean it appears just as English in the list - but should work correctly: it's US English (the missing locale issue was already logged and should be fixed soon).

Thanks, this works! :)

Link to post
Share on other sites
On 1/18/2020 at 10:11 AM, ianstudio said:

On my Mac my 3 Preferred Languages are set as: English US, French and Italian, and my main language is set as English US.. I still get that same issue of having only English (United Kingdom) accessible for spelling in Publisher when it comes to English.

However if I change my Region (under Language & Region) from Switzerland.. to United States, then in Publisher my choice for spelling changes from English (United Kingdom) to English (without any further mention next to it..).

Of course I will not keep my Region set to United States as I want my temperature, units etc to match my culture.. at the Mac System level..

 

 

Ah! This is probably my issue. I live in Brazil, but I have my language settings set to US English. All is fine on my computer, and in Affinity Publisher preferences I can select English US, but upon restart, this option doesn't show in the Text Style option. I'd really rather not change my region to US to avoid a weird bug. I too prefer my temps, units, etc. to match the culture I'm living in on my computer. 

Link to post
Share on other sites
On 2/28/2020 at 9:23 AM, MEB said:

Hi big smile,
Go to System Preferences > Keyboard section, Text tab (on top), click the Spelling dropdown on the right and select the last option Set Up.... Add/tick U.S. English  and press Done. Restart Affinity Publisher. A new English option should appear in the Language dropdown now. It has no locale/region specified - i mean it appears just as English in the list - but should work correctly: it's US English (the missing locale issue was already logged).

OMG! I should have read further. Who would have thought 'Automatic by Language' would have been set to UK English??? Restarted Publisher after updated the System preferences... and now I can find all the styles with the 'missing dictionary' error and fix them so it stops underlining all the differences in spelling between US English and UK English. Thanks so much!

Link to post
Share on other sites
  • 3 months later...

I've done all the forementioned steps for the spell check options and still see only English UK in Publisher. No English US. My Mac system language setting is U.S. English, keyboard setting is also U.S. English.

Could the problem be that I'm still in "trial" mode?

I'm on an iMac running Sierra 10.12.6, live in Greece.

Link to post
Share on other sites

I have exactly the same issue: System Preferences / Spelling set to US English, as well as in Affinity Publisher General Preferences. Still no option to select US English for any of my Text Styles, only option is UK English. Mac OS 10.15.4, Publisher version 1.8.3.

Link to post
Share on other sites
8 hours ago, Stoney said:

Could the problem be that I'm still in "trial" mode?

Welcome to the Serif Affinity forums.

No, that is not the problem. The Trial and Retail versions are identical in functionality.

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1048 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1048 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites
30 minutes ago, melamers said:

I have exactly the same issue: System Preferences / Spelling set to US English, as well as in Affinity Publisher General Preferences. Still no option to select US English for any of my Text Styles, only option is UK English. Mac OS 10.15.4, Publisher version 1.8.3.

Welcome to the Serif Affinity forums.

Do you have a plain "English" available for a Spelling Language?

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1048 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1048 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.