Jump to content

Recommended Posts

This really surprise me. 
I've been trying Mirroring but instantly I heard all the power of my fans, was really weird cause when I'm using Blender is really silent.
So, I launched the task manager and... look that! 

All the work is over my CPU, meanwhile my Quadro is just yawning!

So I wonder, if this is a this a bug

 


image.thumb.png.8325ca537cc85e885daaa2075a3ccbc0.png
 

Share this post


Link to post
Share on other sites

Hey Hanu,

I'm not so sure this is a bug unless it is causing you any performance issues. Affinity will always, when possible, use 100% of your CPU.

If I enable Symmetry mode, I can only get my CPU to about 75% when I aggressively squiggle on the canvas with the same settings you are using. Can you check to see if you are using WARP from Preferences > Performance? If I set my machine to use WARP I hit 100% usage instantly.

Share this post


Link to post
Share on other sites

@Hanu

Whilst the CPU here does the bulk of the work, it certainly isn't being pushed that hard (also the video is being recorded at the same time).

The attached video shows the CPU usage as the Mirror Filter is exercised.

My PC has an aging i7-2600 Sandy Bridge CPU, 16GB of RAM and a GTX1050ti 4G graphics card.

OS is Windows 10Pro, 64 bit v1093 build 18362.418

The image I've used is 4912px x 3264px.

Share this post


Link to post
Share on other sites
5 minutes ago, Greyfox said:

My PC has an aging i7-2600 Sandy Bride CPU

I’m guessing you meant to type ‘Sandy Bridge’!


Alfred online2long.gif
Affinity Designer/Photo/Publisher for Windows • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.8.6 • Designer for iPad 1.8.6 • iPadOS 14.2 (iPad Air 2)

Share this post


Link to post
Share on other sites
9 minutes ago, Chris B said:

 it looks like the OP is using the Symmetry mode for the Paint Brush Tool, not the filter

Yep, now I've looked more closely at his screen shot, I can see that.

Never mind, it gave me a chance to play with the Mirror Filter :5_smiley:

Share this post


Link to post
Share on other sites

Hi guys, In fact, I been using the symmetry mode for paint brush...

And well, even using all the power of my core i7 (8 gen) and 32GB Ram... the experience was really disappoiting and laggy, all this at the expense of burn out practically my hardware. 
 

Share this post


Link to post
Share on other sites

Hey Hanu,

The screenshot tells me you aren't using WARP which is located under Renderer as Joachim_L said.

What size is the document you're drawing on? I've got one set to 8000 px x 4000 px @300dpi and it's a bit laggy but not impossible to work with. If I reduce the size it gets much better. We're also rendering twice the information in Symmetry mode and you're doing long, continuous lines which could start to slow the app down outside of Symmetry mode.

I'm not worried that your CPU is 100% as we will push to use whatever is available. I am concerned that you are experiencing the lag though. 

Share this post


Link to post
Share on other sites

Hey Hanu,

On macOS, we see no such lag (at least I don't) and this is due to Metal. Unfortunately, Windows doesn't have anything like this at the moment but we will be looking at Hardware Acceleration in the future which would likely sort this out. 

Share this post


Link to post
Share on other sites
55 minutes ago, Chris B said:

Hey Hanu,

On macOS, we see no such lag (at least I don't) and this is due to Metal. Unfortunately, Windows doesn't have anything like this at the moment but we will be looking at Hardware Acceleration in the future which would likely sort this out.  

That would be much appreciated. I also experience lag in 2048x2048 documents or larger even without mirroring. Especially when the brush size is more than 300 pixels. Although Metal is better than OpenGL it'd be good enough. Better than nothing.

Share this post


Link to post
Share on other sites
2 minutes ago, Chris B said:

You shouldn't really be struggling with that size document and brush. Can you make sure you don't have your Renderer set to WARP in Preferences?

Yes I just checked, it was set to WARP. I changed it to my graphics card and now it's much faster. Although it lags on 4K with some brushes but that's to be expected.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.