Jump to content

Recommended Posts

I am trying to insert an index into an Affinity Publisher document, but this error is displayed:

"Cannot insert multiple indexes. You cannot insert more than one index in a document."

How do I find and delete the index the document apparently has? I do not see it on any page in the document. Earlier I made some test index entries, which I do not now want to use. The index appears to update but is nowhere to be found.

Share this post


Link to post
Share on other sites

Dan,

Thanks, but I have not made myself clear. The issue is this:

  1. I cannot insert the index, because I get this error message: "Cannot insert multiple indexes. You cannot insert more than one index in a document."
  2. However, the index appears nowhere in the book.
  3. Publisher has no way to find or delete the index.

I think this is a bug in the program. If you insert an index and then delete the pages that contain the index and then save your document, Publisher continues to believe the index is inserted in the document. Therefore, if you now wish to insert the index on  a page or pages, it is impossible, because Publisher does not allow you to insert multiple indexes. At this point you have no choice but to start from scratch by creating a new document.

 

Share this post


Link to post
Share on other sites

Thanks for letting me know and I'm sorry to hear this.

Could you please confirm, what are you trying to add as an Index in your document? How are you adding this Index please?

As a test I have added 'medical' as an index into your document provided via email and this was added without issue/error message.

19 hours ago, AFY7 said:

If you insert an index and then delete the pages that contain the index and then save your document, Publisher continues to believe the index is inserted in the document.

With the Index Studio open you can Update the Index by using the following icon at the top of the Studio - 

image.png

Or alternatively delete an index by using the Trash can icon in the same location.

Share this post


Link to post
Share on other sites

Dan,

I appreciate your efforts to help me, but I don't think you understand the issue.

I know how to use the index panel. I can add index entries and delete them. This is not the problem.

You will find that it is IMPOSSIBLE to insert the completed INDEX into the document.

Here is my challenge to you:

  1. Delete all current index entries.
  2. Create one or two index entries.
  3. Insert the index into the document.

You will find that THIS IS IMPOSSIBLE. You will receive this error: "Cannot insert multiple indexes. You cannot insert more than one index in a document."

You will also find it is IMPOSSIBLE to find the index that Publisher says is in the document.

Share this post


Link to post
Share on other sites

My sincerest apologies, I've since been able to replicate this issue - it appears as though your Index has been added to your Master Page 'IndexFirst'. 

Although you have Index Topics set in the Index Studio, none of these are marked, meaning your Index is currently appearing empty.
I've spoken with our QA team and they agree that we could implement a special character of sorts, to indicate this - as it's certainly not clear currently.

If you select and delete the 4 frame text objects on your IndexFirst master page, you'll find you're able to insert the index anywhere in your document, without seeing the previous error message - however do bear in mind that before you've marked any of your Index entries, the Index will appear blank.

I hope this helps!

Share this post


Link to post
Share on other sites

Dan,

One more question. I don't know what you mean by "marking" and index topic. Can you explain?

Thanks.

Share this post


Link to post
Share on other sites

Dan,

Sorry. I do know what "marking" is. All my index entries were created by marking them in the text, but now none of them appears to be marked! This is a little puzzling. In any case, my primary problem is now solved. I appreciate your assistance.

Share this post


Link to post
Share on other sites
On 10/21/2019 at 9:15 AM, Dan C said:

I've spoken with our QA team and they agree that we could implement a special character of sorts, to indicate this - as it's certainly not clear currently.

What about a "go to index" option somewhere in the UI, like maybe as a button in the Index panel? Even better, also include that as a button in the error window.

I could be misunderstanding the issue but it seems to me that adding yet another special character to the UI is not going to be of much help if you can't easily find the page where the index starts.


Affinity Photo 1.7.3, Affinity Designer 1.7.3, Affinity Publisher 1.7.3; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.3.155 & Affinity Designer 1.7.3.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.1.2

Share this post


Link to post
Share on other sites
3 hours ago, R C-R said:

What about a "go to index" option somewhere in the UI, like maybe as a button in the Index panel? Even better, also include that as a button in the error window.

I'll log this as a suggestion, although I'm aware that our devs are mindful that we don't wish to clutter the UI without need - but I can certainly see the use case for this option!

Share this post


Link to post
Share on other sites

There is a very simple, very useful, and very inconspicuous modification that would address 90% of this issue. Simply do not allow an index to exist on a page or master page if none of the entries are marked. I think my problem arose because I had edited the text on pages extensively, and the text originally marked to create index entries had been deleted. So my index was inserted but "invisible."

Share this post


Link to post
Share on other sites
1 hour ago, Dan C said:

I'll log this as a suggestion, although I'm aware that our devs are mindful that we don't wish to clutter the UI without need - but I can certainly see the use case for this option!

I understand about not wanting to clutter up the UI but there is a lot of unused space along the top of the Index panel where one more button could be added without adding much clutter:

index.jpg.cf17814a8212ef6f9e2d85af1a386b5c.jpg


Affinity Photo 1.7.3, Affinity Designer 1.7.3, Affinity Publisher 1.7.3; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.3.155 & Affinity Designer 1.7.3.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.1.2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.