Jump to content
Longtimer

Save failed because access to the file was lost.

Recommended Posts

I have at last decided to get to grips with Affinity after using DrawPlus , etc for years.

My first introduction not good. In Designer I spent some time creating a new but simple effort (It included a photograph from my hard drive, some text, a graphic I created and some blocks of colour.) and then 'Saved as'.

I gave a name for the document and selected a folder. I got messages asking should this and that be saved to which I answered yes. (I fancy because I let some items extend beyond the page).

An icon appeared in the folder but when I tried later it would not load back in to Designer. So I created another, similar document (a bit quicker this time) and tried to save that with a new name.

I got the message 'Save failed because access to the file was lost.' Yet the new icon was in the folder with its new name. But that won't open either.

I'm using Windows 10 on  a desk top computer and saving to an external drive.

Help please.

Share this post


Link to post
Share on other sites
13 hours ago, Longtimer said:

saving to an external drive.

Are you saving to a hard drive with a physical connection to your PC (such as USB)? Or are you saving to the cloud? The former should present no problems, but the latter is not recommended. You should download to you local disk, then load and save from a local disk, then save back to the cloud.

If you are having problems with a usb drive, it could be that your connection is faulty. Can you check it?

John


Windows 10, Affinity Photo 1.7 and Designer 1.7, (mainly Photo), now ex-Adobe CC

CPU: AMD A6-3670. RAM: 16 GB DDR3 @ 666MHz, Graphics: 2047MB NVIDIA GeForce GT 630

Share this post


Link to post
Share on other sites

Thanks John but

I am using an external hard drive connected via a USB.

I save files from a number of apps including all the Serif Page Plus, Movie Plus, Web Plus, etc and Word documents, without any problem so the connection can hardly be at fault and there is massive free space.

Bill

Share this post


Link to post
Share on other sites

The file will be created by the operating system at the request of Affinity. The icon is also an Operating System property, depending on the file suffix. 

You have saved files to your disk in the past without problems, but is this still the case? Can you save and retrieve other files since your problems with Affinity? If not, then I suspect it is your connection. If you can, then I am stumped and I will have to leave it to others.

John


Windows 10, Affinity Photo 1.7 and Designer 1.7, (mainly Photo), now ex-Adobe CC

CPU: AMD A6-3670. RAM: 16 GB DDR3 @ 666MHz, Graphics: 2047MB NVIDIA GeForce GT 630

Share this post


Link to post
Share on other sites

I spend much of my life creating posters, booklets, films, PowerPoints and other productions as well as editing old photographs and ones of my own. Some of these since  first starting this post. These are always saved to my external hard drive and retrieved from there without problem so the 'Save as' problem with Affinity Designer is not the connection between my computer and the hard drive. I've also tried saving the creations from yesterday onto my computer hard drive with the same results.

Share this post


Link to post
Share on other sites
Quote

Sorry but it does not have a power saver mode and I'm using the drive almost constantly without any problem before the one with Affinity Designer.

 

Share this post


Link to post
Share on other sites

hi,

I lost a file in AD. i clicked on it from open recent and i recovery box opened i clicked yes but it never opened now i cant find it anywhere on my computer. what do i do?

Share this post


Link to post
Share on other sites

Hi Alecia.

 

I have had similar problems as outlined in this post. I received a couple of suggestions but they have not helped solved the issue so I've just given up and gone back to the earlier Serif Page Plus, Web Plus, etc..

Share this post


Link to post
Share on other sites

Hi Longtimer,

your original problem is hard to diagnose remotely - you've had a few suggestions which haven't worked so need to keep trying until you find the cause.  For example, you are saving onto a USB connected drive - but does it work correctly if you have a file on your main C drive?  If a file won't save to your USB drive, can you open one from there (download an afdesign file from these forums if you don't have one that you know is not corrupted).  You say you can see an icon for the file in explorer but have you looked to see what the file size is (as an indication of whether or not it is corrupt)?  Have you tried creating a very simply file in Designer (eg just a square or circle on a background) and then tried saving that?

Your problem is not a common one on these forums so seems likely to be something to do with your specific set up - unfortunately it just means trying lots of different things to narrow down what the underlying cause is. 

Alecia - sorry but I've not had to use the file recovery so can't help you with that. 

Share this post


Link to post
Share on other sites

Hi Clive.

I have three external drives, generally used for different purposes (all USB connected). I have no problem saving to these drives and downloading from them, or moving files between them, with a considerable number of applications including All the Serif applications pre Affinity.(I have been using and updating all the Serif application since they were first launched). So I use the drives for Web Sites, Photo Editing, producing posters and booklets. I have no save/recover problems with these on any of the drives or my 'C' Drive.. I occasionally use Microsoft Word, Excel and PowerPoint. I use music creation and editing and sound editing applications, screen capture and OCR applications and have no problems with these. So a large number of file formats are OK.

I have tried a simple creation in Affinity Design a number of times but the same problem persists on all my drives. Files I created in Affinity Publisher and Photo have no problems.

Non of my drives are anywhere near full.

The icon which appeared shows no attributes except the Affinity design - it has no information of file size or type.

There have been other threads concerning 'save' problems but not the same as mine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.