Jump to content
anweid

Random crashes with pinned objects

Recommended Posts

With the German Affinity Publisher 1.7.3.481 (Windows), as soon as I do lots of things to make pinned objects behave properly (mainly in a double-sided document with mirrored margins), I get random crashes: Publisher just vanishes without trace, without error message, without anything. And the reason why I sometimes have to do lots of things with pinned objects is that there seems to be a number of odd tweaks in the implementation that make pinned objects behave strangely or unexpectedly, so lots of fiddling is involved.

Since this happens randomly and on more or less all files I tried, I cannot send you an example file, but just rant a bit. Documents without pinned objects don't regularly produce crashes (as far as I remember).

Andreas Weidner

Share this post


Link to post
Share on other sites
13 hours ago, anweid said:

With the German Affinity Publisher 1.7.3.481 (Windows), as soon as I do lots of things to make pinned objects behave properly (mainly in a double-sided document with mirrored margins), I get random crashes: Publisher just vanishes without trace, without error message, without anything. And the reason why I sometimes have to do lots of things with pinned objects is that there seems to be a number of odd tweaks in the implementation that make pinned objects behave strangely or unexpectedly, so lots of fiddling is involved.

Since this happens randomly and on more or less all files I tried, I cannot send you an example file, but just rant a bit. Documents without pinned objects don't regularly produce crashes (as far as I remember).

Do you use fields at the same time? Some time ago I documented a bug where the program crashes when using pinning and fields at the same time. As far as I know, this bug has not been fixed yet.

 


My Specs:
- Processor: AMD Phenom™ II X4 955 Processor 3.20 GHz- RAM: 8 GB
- Graphics card: NVIDIA GeForce GTS 250
- Monitor: SyncMaster F2380 (resolution 1920x1080)
- Operating system: Windows 10 Pro (1803) / 64 bit

Share this post


Link to post
Share on other sites

The document where the problems mainly occur uses some fields in the master page's footer (author, savedate, filename, pagecount), and nowhere else.

Publisher also crashed once when trying to open this document, but I also couldn't force that error again...

Andreas Weidner

Share this post


Link to post
Share on other sites
11 hours ago, anweid said:

The document where the problems mainly occur uses some fields in the master page's footer (author, savedate, filename, pagecount), and nowhere else.

Does APub crash even if you remove the fields?


My Specs:
- Processor: AMD Phenom™ II X4 955 Processor 3.20 GHz- RAM: 8 GB
- Graphics card: NVIDIA GeForce GTS 250
- Monitor: SyncMaster F2380 (resolution 1920x1080)
- Operating system: Windows 10 Pro (1803) / 64 bit

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.