Jump to content

Search the Community

Showing results for tags 'apply image'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Affinity Support
    • News and Information
    • Affinity Support & Questions
    • Feature Requests, Suggestions & Discussions
  • Learn and Share
    • Tutorials (Serif and Customer Created Tutorials)
    • Share your work
    • Resources
  • Bug Reporting
    • Report a Bug in Affinity Designer
    • Report a Bug in Affinity Photo
    • Report a Bug in Affinity Publisher
    • (Pre 1.7) Affinity Range Bugs Forums
  • Beta Software Forums
    • Affinity Designer Beta Forums
    • Affinity Photo Beta Forums
    • Affinity Publisher Beta Forums

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 13 results

  1. Hello. Is there any "apply image" function in AP similar to PS CC's own "apply image"? I want to use it for "apply one channel of N layer to current selected mask", or "apply one channel to another channel for RGB mixing - with different opacity and blend modes", etc. It's one of my most used functions in PS CC. I use it almost daily in the winter when it's dark outside, just to give blue channel better SNR by replacing whole or part of the noisy blue channel. Thanks Aleksander
  2. Hello DEVs First off, thanks again for great software, I've been sending ~250 portraits through it since I bought it, and I love how the application just simply replaced Photoshop Over to my "needs".. I really need some features from PS days, and I hope you guys see why. "Apply Image" in Affinity Photo is not alike PS CC's version of it. I used to use this often to grab an RGB, R, G or B. CMYK or C, M, Y, K or even LAB L, A or B from a layer, a document or a file on the disk, then "apply" it as a mask - inverted or not - on to the selected mask, usually in normal or luminosity mode. I even use it for blending K channel from a dublicate CMYK document in to actual documents RGB composite to enhance faint details which is almost lost. I also use it to mix one of the RGB channels from same document in to the worst channel to enhance the details and remove noise (usually B channel), its called luminosity blending, check out Lee Varis and Dan Margulis photoshop videos. I don't see this is possible in Affinity Photo with the current "apply image", and I wish I had the same blending options in it like default layers so it will be easy to fix a "bad" channel in a image Check video below in this post. I also wish I could set one of the info readouts to a default readout, LAB for example, because I use this more often than RGB or anything else. Left side could be document format. I can change to LAB right now, but it doesnt stick to next image. I love to be able to save my own defaults than white and gra. Every single time I use this I have to go and manually set left one to black and right to white anyway because I rarly use this on other things than masks. It is really annoying After pushing through those 250 portraits since I bought Affinity, I'm really getting tired to recheck "current and below", I never retouch on background or main pixel layers and wouldn't suggest anyone to do it either. Make a new layer then use the healing brush with "current and below" is the safest way to use it anyway, so could it be possible to have persistent settings on these as-well? Check next 5 minutes to see what I mean of luminosity blending: Thats all for now Best regards, Aleksander
  3. Hi All, New to Affinity, but does anyone know if you can use apply image on a layer mask? The link I attached here leads to a video describing what exactly I mean. Thank you! Ronny https://youtu.be/lwA34y8ZUbw
  4. I have 2 Documents: - IMAGE A, which size is 1000*1000px and - IMAGE B, which size is 4000*4000px I'm recording 2 macros while working on IMAGE A, which while running makes new layers on top, so at the end of the 2 macros the document has 4 layers (ALL NAMED) - (Pixel) - Composite (Pixel) - Effect (Pixel) - (Background) Basically, the 1st macro duplicates the background layer, runs a filter on it, then makes a composite, making a third layer. On this composite layer I run "Apply Image" and select the Effect image as source layer and it gets applied the composite. Afterwards I drag an external image (logo) on the 4th layer, and run the 2nd macro, which moves the logo 10px to the right. I save my macros, export them, then load them back again to use on my IMAGE B and the next thing happen: 1.- When running "Apply Image" on IMAGE B, i get the same source layer from IMAGE A, and i mean literally the pixel info is saved on the macro and I get a weird blend of 2 different documents. What I'm expecting is the macro to record "Apply layer named 'effect' to the layer 'composite'" 2.- When I get to the logo layer macro, the "transform" step scales to fit the IMAGE B dimensions, so I get a "400% Scale Y", "400% Scale X" "40px Offset X" although I'm only recording to "offset 10 pixels to the right". The expected behavior here is that only the settings I'm changing get recorded and in the same units I'm recording them. I don't want my logo to be scaled, I want its original size to be at 100%, and move it 10px to the right, exactly 10px, not a proportion of the document, otherwise I would specify a percentage value, which I actually noticed it doesn't accept. This behavior gets even worse when I try to run the macro on an image with different aspect ratio, I get weird percentages and values on my transform settings.
  5. lucarubino

    Apply Image

    HI! I'm trying to use Apply image on iPad but I have unexpected results. First of all, how I can select another layer as source? In Desktop version I have to drag the layer on the Apply Image filter's box. (Why not to show all layers in the list???) Here on iPad it doesn't work. I didn't find any way to make it works. And I made a macro on Desktop version, doing something like this. Of course, it works with every single images. If I import that macro on iPad, I have very odd result. Something doesn't work at all on iPad with Apply Image.
  6. When using Apply Image equations, I am expecting to see a completely greyscale image when Da and Db are set to constant 0 in LAB space, however I see a heavy blue tint. See attached screenshot, left side should be greyscale instead.
  7. Blending-related wish list: Adding "Use beneath layers as initial Destination" button in Apply Image filter.Such button would allow for typical use case when you want to perform custom blending. Nowadays you have to: temporarily hide the layer "S" you want to blend, Merge Visible, unhide the layer "S" and move it below new merged layer "D", switch to layer "D", Apply Image and drag layer "S" onto its dialog window to use it as Source. Supporting presets for equations in Apply Image.It's obvious enhancement for better automation. Defining custom blend mode via Adjustment Layer (possibly called Blend Adjustment).It would work for such layer only when it is a child layer. Presets here are also crucial. Defining custom global (accessible in all documents) or local (accessible in current document) blend modes.The most robust solution for users performing repeatedly their own custom blending. In Blend Mode Manager there should be a way to see (in a read-only manner) already existing blend modes with equations (for blend modes expressable in plain equations). Blend mode definition should be performed using equations where:S (Source) = current layer [aka Active or A] D (Destination) = beneath layers [aka Background or B] In case of Blend Adjustment source would be the parent layer. Example of custom blend mode: Remove DR=(DR-SR*SA)/(1-SA) DG=(DG-SG*SA)/(1-SA) DB=(DB-SB*SA)/(1-SA) DA=DA(It doesn't make sense for truly opaque layer, of course.)
  8. I want to use Apply Image to apply the R channel to a photo in darken blend mode, as part of a procedure to darken the sky (I realise this might not be the best way to do this). But AP ignores the darken blend and gives me Normal I've got one layer with an RGB photo of a building with a sky above. The R channel is lighter than any other channel except in the sky. - I go to Apply Image and select Current Layer - In the equations, I set DR = SR, DG = SR and DB = SR - I set the Apply Image blend mode to normal; I see the grey scale R channel as I expect. - I set the Apply Image blend mode to darken; I see the sky grey scale (equal to the R channel) and the building in colour, as I expect. - The bug is that immediately I tap the tick to accept the Apply Image filter the building changes from colour to grey scale, equal to the R channel. It is as if that tapping the tick changes the Apply Image blend mode back to normal. iPad Air 2, iOS 10.3.2, AP 1.6.3
  9. Hi, Could someone shed some light on this for me? I have followed the tutorial on greyscale blending and have come across the following problem. I follow all processes and then, when I click /drag the new greyscale pixel layer into the Apply Image Filter Interface and click 'equation' the new 'greyscale layer' is not displayed, the original 'background layer has not been replaced, I therefore cannot bring back the colours using the equations. Have I set it up incorrectly? Many Thanks Simon R
  10. Hello, I have a question regarding the "Apply Image" function. I saw a tutorial where Apply Image was used in Photoshop to change the mask of an image to become the source image but as a mask (so just the dark and bright information). It was used to blend multiple exposures together. Is it also possible with the Apply Image feature in AP, or is there any other option? I hope it is clear what I mean, because I find it hard to explain. Thanks in advance :)
  11. Trying out the awesome new Equations feature in "Apply Image", I found that expressions that lead to out-of-bounds values are not handled gracefully (8-bit mode). My test was a simple color difference greenscreen keyer: DA = SG - max(SR, SB) The result has artifacts where this expression yields negative results. Doing the clamping manually works fine. DA = max(0, SG-max(SR, SB)) It would make more sense to always have this clamping performed automatically and implicitly for non-float documents. This would also ensure that more expressions and macros created for unbounded floating point images will work with 8-bit and 16-bit documents without adjustments. I have also not been able to find out how to access the current pixel's coordinates inside Apply Image (seems to work for "Distort > Equations" expressions) and what the syntax for modulo operators is, but that's likely either due to my stupidity or it not being implemented yet and not a bug. Also, I noticed a strange 1-pixel diagonal line pattern when choosing a source layer and then navigating to an adjustment layer in the Layers panel.
  12. Hello, i try to apply the image i am working on to a mask. In PS i do it straight forward, create the new layer (with a mask) - select it and use Image > Apply Image ... I fail to do the same in AP ... would be nice to get a tip. BR and thank you Sascha
×