Jump to content

Search the Community

Showing results for tags 'afd-867'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Affinity Support
    • News and Information
    • Affinity Support & Questions
    • Feature Requests, Suggestions & Discussions
  • Learn and Share
    • Tutorials (Serif and Customer Created Tutorials)
    • Share your work
    • Resources
  • Bug Reporting
    • Report a Bug in Affinity Designer
    • Report a Bug in Affinity Photo
    • Report a Bug in Affinity Publisher
    • (Pre 1.7) Affinity Range Bugs Forums
  • Beta Software Forums
    • Affinity Designer Beta Forums
    • Affinity Photo Beta Forums
    • Affinity Publisher Beta Forums

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 4 results

  1. Hi there! I made a quite simple design in AD Beta .333 and exported it to SVG (please find both files attached, export was limited to the selected group). Unfortunately the clipping didn't work as expected. Instead of a clipped Text (by the rectangle) I got a design in which the text is staying on top of the rectangle (when opened with AD). Did I do something wrong here - or is it an export glitch? Cheers, Volker bad-svg-export_ad-1-7-333.afdesign bad-svg-export_ad-1-7-333.svg
  2. So, I generated this SVG file in Affinity itself and saved everything perfectly; as shown in the Opera view and also when I open in Inkscape, the SVG file is working perfectly (attached prints); only that, when I re-open the SVG file in Affinity, the layers that were one inside the others - to generate the format of the photo - get lost; they remain in the file, but as if they were hidden below the photo. I guess it's not intentional and, as seen, I'm reporting it as a bug. Thank you, guys
  3. Affinity Designer appears not to import the following SVG correctly: the `transform` on the `g` element is not being applied to the `clip-path` on the `path` element. <?xml version="1.0" encoding="UTF-8"?> <svg xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" viewBox="0, 0, 200, 100" width="200" height="100" xmlns="http://www.w3.org/2000/svg"> <defs> <clipPath id="c1"> <path d="M 50,5 5,50 50,95 95,50 Z"/> </clipPath> </defs> <g transform="translate(50, 0)"> <path clip-path="url(#c1)" d="M 20,20 20,80 80,80 80,20 Z" fill="blue" stroke="red" stroke-width="5"/> </g> </svg> I tried to find how W3 spec says these attributes are supposed to interact, without success. However, Safari, Chrome, Firefox, Sketch, and Graphic all applied the transformation to the nested `clip-path`, and I did not find any other applications that matched the behavior of Affinity Designer.
  4. Hello, I have downloaded the trial version and have to say it is very nice. I loaded my current tvOS projects character SVG which has about 110 frames of character animations. Each frame comprised of about 30 elements. So a good test to compare to Inkscape 0.91 for performance. System is fairly maxed out 2011 iMac. Pros: Wow it is fast and scrolls in and out so smoothly Using the same keyboard shortcuts as the rest of OSX is nice as well Near perfect import of the test SVG (see cons for issues) Easy to use so far Awesome export options Cons: Clipped & Masked items in the test SVG did not import clipped or masked. This is actually quite a mess to have to clean up by hand. Color picker eye dropper was not nearly as intuitive to use as pretty much any other apps I have used. The click & hold then move selection area to color felt very awkward. Much prefer the select tool then move to area and click on color desired style eye dropper tools. Not so happy with the path node tools either. Enjoy having control arms on all three types of control nodes in Inkscape. Questions: 1. Is there something I am missing to fix the problem with Clipped elements on SVG import? I use this technique often in Inkscape so getting this right on import is important. Just to much work to fix it all by hand on every image and if I can't bring in all my old art it negates the value of moving to AD from Inkscape. 2. Is there a way to get a color picker that works more in line with the select object, select tool, select color (like inkscape) with out the need for the click/hold/drag AD uses? Being new I bet I missing something here. 3. Path node control arms for all nodes types would be nice, so am I missing the obvious on how to get them to appear? 4. I know they keep this tool up to date so I will ask about PNG export without transparency (Alpha). Anyone that is developing for Apple knows that they have moved several items to no Alpha channel and that they prefer PNG format files. The latest is Image Stacks for tvOS apps require the back most layer to not have any Alpha. So could that becomes a PNG export option? I ask about PNG because it is easier to keep all images in the same format vice a mix of PNG and JPG files. Also right now Apples tool chain for image stacks is young and mixing PNG/JPG in the stack has resulted in fun and for me it being easier to use Preview to fix the alpha channel as required and stay all PNG files. 5. Speaking of tvOS will there be an Export option to create the Parallax Images (.lsr files) added at some point? I have an idea on this might be done. Special template with 1 to 5 layers (range that Apple's LSR format allows. The export option would export each layer into the LSR file (layer 1 being back most) and then counting up from there. It would sure be awesome to have something like this for AD given that Apple released a plugging for PhotoShop to do just this. Again great product. Loving the trial version. Besides the clipped and masked objects not importing correctly I am thinking this is a clear move from Inkscape for me. Look forward to hearing back. Matt
×