Jump to content

Search the Community

Showing results for tags 'Bugs'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Affinity Support
    • News and Information
    • Affinity Support & Questions
    • Feature Requests & Suggestions
  • Learn and Share
    • Tutorials (Serif and Customer Created Tutorials)
    • Share your work
    • Resources
  • Bug Reporting
    • Report a Bug in Affinity Designer
    • Report a Bug in Affinity Photo
    • Report a Bug in Affinity Publisher
    • (Pre 1.7) Affinity Range Bugs Forums
  • Beta Software Forums
    • Affinity Designer Beta Forums
    • Affinity Photo Beta Forums
    • Affinity Publisher Beta Forums

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 102 results

  1. PLEASE HELP: All Affinity Products Stopped Opening on Windows 10 I have a Surface 7 Pro with 2 external monitors and have been using Affinity products on it for some time. I've purchased all three Affinity products and been quite happy with them, up until now... Went to open them today and none of them will open, all have a very brief loading cursor then nothing at all. 😞 Nothing in: %APPDATA%\Affinity\Designer\1.0\Log.txt 0KB %APPDATA%\Affinity\Photo\1.0\Log.txt 0KB %APPDATA%\Affinity\Publisher\1.0\Log.txt 0KB Windows 10 20215.1000 Intel Iris Plus Graphics 27.20.100.8681 Affinity Designer 1.8.5 but also affects Affinity Photo 1.8.5 and Affinity Publisher 1.8.5. All were working just fine up until today. I've restarted several times. Tried without the external monitors attached. Etc. Nothing seems to help at all. I have none of the known third party apps that cause issues. I replaced the Intel Iris Plus graphic drivers with the latest version from Intel and that did not help either. PLEASE HELP I have work I desperately need to do and I can't even get any of the apps to launch anymore. 😢😭 I need to get this working again ASAP. 🙏 If a developer needs to access my machine remotely to debug that can be arranged.
  2. Several categories in Adjustments are empty, see attached screenshot. Maybe language settings (Photo is English, Ipad is German)? Georg
  3. I know that Big Sur is only a Beta but when I sometimes open 10 NEF image files, the system crashes (didn't happen before upgrade). Guessing this will be fixed when the actual release of Big Sur is out. iMac (Retina 5K, 27-inch, 2019) processor 3 GHz 6-Core Intel Core i5 Memory 32 GB 2667 MHz DDR4 Graphics Radeon Pro 570X 4 GB Ram usage limit set to 60416 MB
  4. ***Affinity feature requests*** * Global Gradient Swatches. Are they this hard to implement in affinity software...it's been 3 years alomst and the top design app for mac still doesnt support global gradient swatches, why is that? * Dynamic Styles. Yes, a workaround for this is using a symbol but having a dynamic style instead of using a Symbol can be used in many areas, means, i can implement a dynamic style with shadows and glow to a circle, a rectangle, a polygon...while having ability to manipulate and watch effects like shadows taking change on multiple objects in real time. You get the idea, right? Specially for Ui/Ux designers. * Symbol lock (Sometimes we end up making changes to symbols only to zoom out and realizing those changes impact symbols on the entire page. Hence a special symbol locking mechanism would be very welcomed where we can lock symbols so that they can be moved and resized but cannot be modified or implement changes to their appearances) * Shape builder tool (We all know it how much us designers are craving for this handy dandy boolean operation tool. come on team serif * Shape Blend tool (least priority but essential tool) * Mirroring tool (I get the idea to use symbols as workaround for mirroring but wont a separate tool make tasks a lot easier for logo/graphic designer?) * Functionality to add more Api within Affinity software to grab assets from websites, just like unsplash is currently supported. (https://developer.flaticon.com/landing)
  5. Hello, Hi, Moin! I described my issues regarding the PDF format but they may apply to all other formats and also Images. (In example like improved the linking function etc.) I encountered following bugs: Pdf Bugs Fonts which are used and embedded in the PDF but not installed on the System are not displayed. No matter if PDF is embedded or linked. Preflight notices it but a button only links to the font manager wich shows everything is fine (since it only shows font issues in the afpublisher file). Using the embedded font/font Letters like a PDF reader may be a solution. Linked PDF cant be edited anymore like in the usual way of double clicking it. PDFs should be editable if embedded or linked. When a font is not installed and only embedded in the PDF, Replacing the fonts, creating vector paths from the embedded font, or using the embedded font/font letters may be a solution to continue the workflow anyway. Not a Bug but: Please make it more comfortable to relink ressources in the document. Like if the tree structure of the files and folders remains but with a change to a new location (a new drive). In example Lightroom searches for more missing files in same directory that has been used to relink another file. Sorry if some of the terms i used regarding Affinity Publisher doesnt make sense ... im not using the Affinity Suite in Englisch but in the latest Version 1.8.3
  6. As shown in the image, I placed two objects on top of each other and slid the top one up a bit. I gave the top object 3pt width and set it as the inner width. But there is a very fine (maybe 1px) fill color around this object. The same problem persists when I visually export it. You can see it by zooming in the attached image. Is this a bug?
  7. Hi, Just bought my Affinity Designer recently. At start, all seems to be normal until i substracted a circle shape and try to add gradient to it and suddenly i can't drag my mouse to Zoom. I can olny click to zoom in and push Alt key to zoom out. And also, my Gradient node when i want to edit it, it lag so bad. So the only way to stop the bugs is to close and re-open Affinity, but then it happen again. Please help, i just bought it and it's so unpleasant to have this bugs. Iam using Win 10, i5 9th gen, GTX 1050, 8GB RAM Thank You
  8. Bug 1: Embedding a document into another one and rotating it doesn't rotate the light sources. Reported this for the previous version already, original report: Bug 2: Aligning to masked object behaves differently from aligning to masked curve I reported this here already: Bug 3: Alignment drop down menu can not be moved to a panel Feature Request: Alignment drop down menu can not be moved to a panel Bug 3: Copying the style of one object to another changes the settings. Steps to reproduce: a) create a rectangle, size doesn't matter b) right click it -> Layer effects -> "Bevel/Emboss" -> slide the radius to "20px", other settings do not matter. -> apply style with "close" c) select the rectangle and press CTRL+C to copy it to clipboard. d) create a 2nd rectangle of different size (make it much bigger to have a more visible effect) e) press CTRL+SHIFT+V to paste the small rectangles style f) check the settings of the new rectangle: right click -> Layer effects -> "Bevel/Emboss". The radius is now something totally different from the original "20px". This bug also happens to other layer effects and the "Scale with object" setting does not have an impact. Fun fact: If the 2nd rectangle is created by copying the 2st rectangle right after step (a), then resizing it and going through the rest of the steps (that means adding some layer effects to the 1st rectangle, selecting it, CTRL+C, selecting the 2nd rectangle, CTRL+SHIFT+V), the layer effects stay in tact! That's super weird to me! Bug 4: Weird rendering artifact for sharp Bevel Applying a sharp bevel/emboss with a 45deg angel light source (that's not too uncommon ... 🙄) causes a weird dark line on the edge. It should not be there, it should all be uniform. Same for the white line on the opposite side. Final notes. Ok, that's the bugs I found so far. Oh and any news on a vector envelope/perpective/distort or scissors tool? I'm just asking for a friend ... Naja, non the less I like seeing you guys working to improve the software. Keep it up.
  9. I’m having a recurring issue when trying to subtract an overlapping shape from the object below. Every time I try it, the resulting new object is distorted. This is something I’ve not had issues with until now. Same thing is happening when I try to add multiple objects together. Examples attached.
  10. I have the following problems with the upgrade of 1.8.1 which I did directly from the same Publisher programmme. 1. Prepapring a PDF for printing with 1.8.1 ends up weighing not twice but three times more! I had to make a correction on a document I made last year that weighed only 274 MB. I made a correction on the text, and now the same document, following the same settings I used before when exporting as a PDF file for prining, weighs 1,23 GB!!! 2. Problems importing PDF files into your document. This problem I've had since the very beginning with every Affinity programme. I produce a monthly magazine and most of the adverts are sent as PDF files. Every single programme in Affinty (Designer, Photo and Publisher) completely deconstructs PDF files and sorts them out as layers, and if you don't have the exact same font as the one in the pdf, it will replace it for another. The only way I could work this out, is by converting the PDF files into images—using Photoshop! 3. I don't know if pre-flight was available before, as I never noticed it—but with version 1.8.1 it's mandatory! It opens all the time, and according to your pre-flight everything you have done is wrong (all buttons are orange or yellow)! The problem is that all the mistakes it detects are proper names, the names of cities, foreign words or any word that doesn't have a meaning in the English language (which is the one I use). So a name like MacHale, the spelling checker will ask you to change it into 'manhole' or some such absurdity. Is there a way to avoid having the spelling checker check spelling to proper names, cities and/or foreign words? Again, with version 1.8.1 the pre-flight signaled with a red button something wrong with an image, but no explanation. It happened to be a PDF image as mentioned in the above point. So I had to convert the PDF into an image, and then place it back in the document. The pre-flight red button then disappeared. Oddly enough, this same PDF image had been used last year and sent to the printer with no problem. Now PDF images pose a problem with version 1.8.1. 4. This isn't a bug, but rather a question. I have to send a document to the printer by the end of the month, and can't wait another 6 months until these bugs are fixed, so is there anyway of downgrading to a previous version? Do I have to first bin the 1.8.1 version an then re-install an older version? I haven't checked Photo or Designer upgrades yet, but for the time being these are the bugs/problems I have with Publisher 1.8.1. Please I need a reply asap, as I have to send a document to the printer by the end of the month! Best wishes!
  11. Hey, in the new versión it doesn't work CMD+Z, and this function is also not available in the "EDIT" menu. impossible to undo!
  12. Windows 10 Affinity Designer 1.8.0.585 Additional information This is happening when I'm editing a file that has been created with an older Designer version. With a completely new file, the inside stroke works as expected. Steps 1. Create an ellipse 2. Add a stroke 3. Change stroke alignment to inside Expected result The stroke is aligned inside Actual result The stroke is invisible, nothing is happening
  13. Hi, I started to use Affinity Photo for painting on the iPad lately and I am really surprised that is contains so many annoying issues. The reason I started trying AP is that Paolo Limoncelli / Daub, whose brushes I love in ClipStudioPaint, was raving about AP's new brush engine and offered nice brush sets for it. So I went ahead and bought AP and the brushes. And also Frankentoons nice Neptune Kit. And indeed, AP's capabilities look promising. But working with AP feels like using beta software, really. Below I am listing a couple of the issues I am repeatedly seeing. 1. When changing to a different brush and starting to paint often AP will start a straight line from some random point to where the canvas is touched with the pencil. This cannotbe undone with undo, but only by selecting an older state from the timeline. Also if for some reason it is not immediately recognized and you see the line only later, it needs to be removed manually, because the painting has progressed in the meantime. 2. Sometimes when changing to the browser to search for a reference without having saved explicitly, the previous changes to the painting will just be "forgotten". 3. Resize rectangle for selection disappeares without reason 4. Playing a macro (when editing a photo this time) pretty often crashes the app. The same macro will not always crash the app, though. 5. Doesn't support iOS' screen split (ok, no bug, missing functionality) 6. UI elements continue to be shown (layer rectangle when trying to move a layer). Needed to stop and restart AP to get rid of it. 7. Ignores changes to brush settings (tried changing the associated tool of a brush to "erase", which had no effect) 8. Sometimes toggles off controls when I just select a tool, like erase or brush. 9. If I really switch off controls intendedly with the icon at the top right, they will come back pretty soon on their own The above list only contains those issues I noted down after really becoming frustrated. There might have been more. The last update to AP is 2 month ago, any chance of getting an update to a more stable version soon? I do not think I want to use the software as is more. In addition to the above bugs I think the intuitiveness of the UI needs to be improved as well. Just a few examples of functions were I needed to search on the net, which I did not need for any other painting program for such basic functions ever: - Naming a layer - Removing a layer group which was mistakenly added (only possible via timeline, or maybe I did not even find the intended way) - Picking a color (reference spot is under the finger, instead of being slightly shifted and seeing the actual place in the picture to choose from) - Selecting and working with the selection (changing personas all the time, argh) The above might sound harsh, but I have used multiple painting apps now (CSP, Artstudio Pro, Sketchbook, Paintstorm Studio, MediBang Paint) and AP feels almost as being the least mature. PSS is not really ideal also, but hasn't crashed or malfunctioned as often as AP did for me. I saw that there is a sub-forum to report bugs, but with such a long list, I really do not feel like doing for each individually. All of them should be easy to reproduce. Feel free to move to that forum if more appropriate. Environment: iPadOS 13.3, iPad Pro 12.9 latest gen. Regards, FrayingCanvas
  14. Hey there, I'm having an issue with my graphics tablet(Huion 1060+, in case that helps) in Affinity Designer. Whenever I try to write with it on the canvas, it switches from whatever tool I'm using to the Eraser tool, no matter what persona I'm using. I've tried turning off and resetting Affinity's keyboard shortcuts, resetting my tablet to defaults, restarting the program, and resetting fills, brushes, object styles, text styles, and user defaults, all to no avail. It works fine when I use my trackpad, and it was working with the tablet earlier today. Any suggestions? Thanks!
  15. Recently had a colleague asking about my thoughts on switching to Affinity Designer from Ai. I've been using Designer since 1.2 and overall really love the program, but this question reminded me of some of the common issues that come up for me daily. So my response was that is was a great program that can replace Ai… but there are some issues so I can't fully recommend you do it. The main issues that stop me from fully recommending the app are: 1. Expand stroke can create truly horrible results, especially if you have variation in the stroke pressure. From excessive points (no simplify path operations either) to weird curves. And the smooth rounded ends of variable pressure strokes become pointed. 2. There is no Free transform tool. Something I sorely miss from Ai to make quick perspective changes on grouped objects. 3. For some reason I find it very unpredictable where the resulting shape of path operations will go. I don't know how much time I waste having to put errant resulting intersected shape back into the group from which it's parents came. 4. And lastly, working in the web, it find it a little inconvenient no to be able to enter colour values (ie. hex, rgb) on the Colour palette. I know there is also the Colour Chooser palette with the number fields, but it is so gigantic and doesn't fit in with the other palettes. If they would just combine those into one, with the option of toggling the colour fields. That'd be so nice.
  16. Whenever I export a logo from Designer as an SVG I noticed in Illustrator CS6 my strokes change. It's my suspicion that when the scale strokes option is selected in Designer for iPad, the data gets lost during export to SVG or upon import into CS6. Anyone else getting this glitch? I suppose a workaround would be to convert those strokes to outlines before exporting but what if client wants me to adjust stroke weight on the fly on their computer? Or on my own? I have Designer for Mac as well but these clients do not. So I would like to know if this is something you plan to address in a future update. Fantastic app by the way! May the Vector Gods smile upon you!
  17. I've encountered an issue with the Move Tool (Black Cursor Icon) after I've saved my file. Once the file is saved, the move tool only selects the objects but will not drag them/move them. I also am no longer able to resize objects perhaps related to the Move Tool's overall functionality. The only way I am able to resolve this issue is by shutting down the entire program, opening it up again then re-opening the file. This can be very disruptive to my workflow, and I do like to save my files periodically to avoid losing any significant work. The video attached shows me saving a file midway, then no longer being able to move selected objects. Thank you, hope this can be resolved soon! System Information: I'm using the Microsoft Surface Laptop on Windows 10 Pro Operating System Version 1803 OS Processor Intel(R) Core(TM) i76600U CPU 2.60GHz 2.81GHz Power saving GPU Intel(R) HD Graphics 520 High-Performance GPU NVIDIA GeForce GPU Installed RAM 16.0 GB 64-bit operating system, x64-based processor Move Tool Issue.mp4
  18. Hi Serif, I'm really unhappy right now. AP on Windows 10. After loading a scan (.tiff file) and working on a document for nearly two hours then hitting CTRL+S to save over the original file (on my desktop) I've got following error prompt: which would be ok if Photo didn't close the document at this moment without allowing me to export a copy... Yes, I'm an idiot and should save more. Or more often or whatever. I agree. My bad. But it's definitelly Affinity Photo's fault and huge error if such a thing even happens. How come AP even allows this to happen? How come that a copy in memory is wiped and user is not allowed to save the progress when Photo at this point knows very well it isn't able to save over the original file? Why Photo didn't make a working backup or something? This is classic Affinity SNAFU, guys.
  19. The constraints in Affinity Designer are seriously flawed. To illustrate, I've attached a file that illustrates several problems at once. Here at least the following unexpected situations happen when trying to change or remove the constraints from the existing objects, or grouping them: Objects change dimensions; Objects change position; Objects get invisible; Objects change scale so they are not proportional anymore; Undo no longer restores objects to their original state; A change to a single object affects all similar objects although there are no symbols in the file. I'm using AD for about a year now. As you may know, I've patiently reported these problems several times but unfortunately nothing changed yet. Please don't get me wrong, I love AD and I appreciate all the work you do. Since working in UI projects (which use lots of artboards, symbols and constraints) is the main reason I adopted Affinity Designer, I'm always trying to circumvent bugs that shouldn't exist in the first place, and these are among the worst. I think they are serious flaws and I'd very much like you to provide a solution. Thanks, and sorry for the long post. Bugs - constraints 2.afdesign
  20. Hi I presume that after last update something went really wrong with expanding stroke function. It is completely broken. I have a lot of work to do, but now I just cant do anything. Any help?
  21. Hi guys, so, I got this problem with the studios, of both Affinity designer and photo, on Windows 10, are not displaying the right way. Right after the start the welcome screen is part white, no buttons showing, I can only work around that "buggy welcome screen" with pushing "ESC". Well, but then, the studio itself is buggy. Sometimes it works, for about 10 mins, than the panels "mix up", buttons vanish ... it's annoying. I tried to resolve the problem myself, but I don't quite get the right term to search for that exact bug. The PC is updated to the fullest. I'm really helpless right now, because working with the software right now, like this, is nearly impossible. I know that the problem could have been, because of the 32 bit and 64 bit versions, but I pretty sure I got the right one installed. Perhaps someone else has the lightning strike idea. I'm at my wit's end. Thanks in advance Mel
  22. Helo guys, I try to make artwork to be curve permanently, and I have problem because The expand stroke result seems weird. Anyone tell me how to make it properly proportional shape in AD before after
  23. The Affinity Publisher application close by itself when I am using "Edit Table Format" and hit "Apply Style To Selection"
  24. Hello! I am fairly new to Affinity Designer and Photo, but I feel that this problem isn’t due to my lack of experience. But if it is, I will be even more grateful for any expert advice and counsel comming my way. I have been using AD and AP for illustrating and I have been noticing some bugs in the raster brush response. I have experiemented with a mouse, a Huion graphics tablet, and a XP-Pen Artist 15.6 tablet. I am finding the same problems using all three when creating art with rasher brushes (especially in Affinity Photo). Today it was so bad that I was unable to much of anything. In fact, AD totally crashed on me today (I was very please that it was able to recover my work though!) With that all laid out on the table— In describing the bugs in more detail: I am experiencing a tremendous amount of lagging and choppiness when I sketch/stamp/paint (especially with bigger brushes or brushes that have been customized/specially made by third parties like DAUB or Frankentoon). Some brushes don’t even show up at all. All of the brushes are super small for some reason, though I am working in 300 dpi, I feel like I should be able to upsize my brushes without any huge problems occurring... I definitely cannot work a document that is any higher in dpi without being absolutely crippled in my sketch/stamp/painting performance. I am not having this problem as much with the eraser tool. I’m mostly noticing it with the paint and stamps brushes. Any help here will be greatly appreciated. (I can provide screenshots if requested. I felt that I wasn’t really able to convey what I’m describing in just a screenshot, but if it is helpful, let me know and I will post some.) Thank you!
  25. Heya, I have run into an annoying issue when using the paint brush in affinity photo with a Wacom tablet on windows 10. Attached is a gif of the issue, but to describe it, each time I try to paint some areas I cover with my bush don't get any colour added, and then i get some weird graphics glitches where areas I have painted are removed. Im using the latest version of Windows 10 and affinity photo.
×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.