Jump to content

Search the Community

Showing results for tags 'bug'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Affinity Support
    • News and Information
    • Affinity Support & Questions
    • Feature Requests, Suggestions & Discussions
  • Learn and Share
    • Tutorials (Serif and Customer Created Tutorials)
    • Share your work
    • Resources
  • Bug Reporting
    • Report a Bug in Affinity Designer
    • Report a Bug in Affinity Photo
    • Report a Bug in Affinity Publisher
    • (Pre 1.7) Affinity Range Bugs Forums
  • Beta Software Forums
    • Affinity Designer Beta Forums
    • Affinity Photo Beta Forums
    • Affinity Publisher Beta Forums

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 801 results

  1. I use the rectangular Marquee Tool quite a lot. When applying a high feather, say 500px, the selection has unwanted rectangles within it. Trying the same thing with the Elliptical Tool I found that the Elipse is changed to two crescents left and right. At 400px it seems alright. It looks like some development artifact that has been missed. I did report this during Beta testing.
  2. I posted this before for the photo beta and it was fixed (i believe), but it hasn't been fixed for Designer. Here is a short video (no audio) of the bug. If you set the export options for a layer, the export button doesn't work until you switch to a different layer and then switch back to the layer you want to export.
  3. Summary When attempting to export a layer slice based on a rectangle with a gradient fill to an SVG with certain settings, Affinity Photo 1.3.4 crashes.Steps to Reproduce Open "AP Slice Crash.afphoto". Note the rectangle layer "transition-gradient" in the document. If there isn't one already, create a slice based on this layer in Export Persona mode. Choose any of the SVG export presets. Attempt to export this slice, either using the "Share" icon next to the slice in the Slices palette, or by clicking the "Export Selected" button. Expected Results Affinity Photo exports an SVG of this slice and continues to function.Actual Results Affinity Photo crashes without exporting the slice to SVG.Notes This crash occurs on OS X El Capitan Version 10.11 Beta (15A215h), which may or may not be related. I've included a test document and a video of the crash occurring on my 15" Retina MacBook Pro (Mid 2013) while the dedicated graphics card is active. AP Slice Crash.afphoto AP Slice Crash.mov Cheers, Joe
  4. I have the full version of affinity photo. I used (played) with liquify persona a lot and pushing almost every button just to see what it does. It's working great. I then click on apply I go back to dev persona (where I was just before) I want to go on photo persona. I click on photo persona it tells me to "develop" the picture. I click develop I'm back on the liquify persona. It doesn't go on the photo persona. did I miss something or is it a bug ?
  5. I made a screenshot, drag-opened it with affinity -designer. selected a portion/part of the image with the marquee tool, cut it (with CMD+X) pasted it (with CMD-V) removed the background layer (e.g. original screenshot/image). pasted an other selection of an image. on slice-export it displays, what could be the original background image. Vector shapes on top the image are omitted at export.
  6. I'm using the free trial version of Affinity Design and this is one bug I noticed. I tried to open a PSD file, some layers of the file have Layer Styles. Upon importing, the layer styles didn't render but the layer is present. I looked into that layer and I saw the "fx" icon and I try to access it because maybe I can try to recreate the layer style. I clicked the 'fx' icon and the app crashed. Not seeing the layer styles from the start is sort of a hassle too because soon I'm gonna ditch my PS and I'm finding a new editing software. What if the PSD was from a client and I'm not aware of the original style provided? That might 'cause some problems. Thank you and I hope you look into this because I'm really trying to find a good software that can import PSD and AI flawlessly First Screenshot: File opened on PS Second: FIle opened on AD (Gradient is gone) Third: FX icon on that layer
  7. They are consistent repeatable crashes on a particular project (haven't tested others) and there are a couple different kinds of them. The original file was a EPS brought in to Designer. I've attached the offending Affinity Document to this post. PDF, SVG, EPS Export as they should. If only one of the shapes in the project is selected, it exports correctly, but not if all shapes are selected. Problem Exports- PSD Export: 1. Select all shapes in the project. 2. Go to Export in the File Menu. 3. PSD Export Tab. Try and do anything and it crashes. PNG, JPEG, GIF, and TIFF: 1. Select all shapes in the project. 2. Go to Export in the File Menu. 3. Go to the desired export tab, Select "Export Without Background" (often crashes here). 4. Try and change the Size parameters and it crashes. Here is a crash report for an attempted PNG export: consistent-crashes-at-export-step-CRASHREPORT.rtf Colonial-Funeral-Home.afdesign
  8. As you can see, this is what I get when I try to export a JPEG. This happens when I open the "logo" file from a PDF, or EPS. In fact, I think it happens from an Affinity file as well. I can't get a real JPEG quality image to export.
  9. When pasting a table from the clipboard that was copied from Word 2011, Affinity designer crashes (without warning; "Affinity Designer quit unexpectedly"). Luckily, the auto-backup saved most of my work. I was expecting that Affinity Designer would produce the table as unformatted text. Apart from that I'm very satisfied by Affinity Designer. I have used it extensively in the past few weeks and I am amazed by the by the blazing speed of the rendering engine when working on (very) complex drawings. Although I can think of many improvements, this app is really really useful. I finally left CorelDRAW for my artwork. Love it, can't wait to see the next beta!
  10. If I enable "Force pixel alignment" in the Snapping options, it seems to almost completely break snapping. I say almost, as if I'm very careful sometimes a snapping guideline will appear if I mouse-over the exact "snapping" position (as if the "Screen tolerance" had been set to 0) - but at any zoom this is impossible as positions are no longer exact, and it doesn't always work either. When I move objects around I see the edges of their bounding box go red/green as they move, so what I'm assuming is happening is that the objects are always snapping to every pixel, and this is overriding all other snapping points. The only non-standard thing about my system's configuration I can think of that might affect this is that I run with my MBP's display set to "Scaled" and "More Space", which essentially turns off the Retina-ness of the display.
  11. First off, I'm not sure if this is the right place to post so I apologize if this is the wrong forum. I'm a college student in the early stages of a big final project. I've been diagramming a section of my city with Affinity Designer. I'm using the trail at the moment to see if I can switch over from Illustrator. Until now it's been a glorious experience. However, I when I opened my Macbook Pro this morning, Affinity Designer (1.2) was unresponsive and my cursor was the dreaded spinning beach ball. I ended up having to force quit out. I figured it wasn't a big deal as I had saved my work last night. However, when I tried to open my file back up I got this error: At this point I panicked a little. However, I figured there were a few things I could try before freaking out for real. Interestingly, I discovered that I could open it no problem in Affinity Photo Beta (1.1.2.24443) I then tried saving it as a .afphoto file and opening it in Affinity Designer. Sure enough, it opens just fine! All is not lost! I was then able to save my work as a .afdesign file and voila! I'm back in business! This episode was a bit nerve wracking as you can imagine. I figured I should probably post about it here so that Affinity could look into it and hopefully prevent this from happening to someone else.
  12. Hi, I just upgraded to the latest version of AD, a lot of great new features - Thnx! Unfortunately, no longer work for me selection fonts (from Character windows/Panel) by pressing the up/down Arrow keys on the keyboard..? as it was before the upgrade. Now I have to click by the mouse each font to view them - with three hundred, it takes endlessly... :/ This is a bug, or I can fix it somehow from the program? Cheers! Marcin
  13. All sorts of issues with exporting slices. JPEGs are exported with a black background. PNG-8 - have a blue background PNG-24 - see to be the only thing working. See attachments. Maybe it's a setting issue I'm unaware of? Worked great in the Beta. S
  14. Hey guys, I'm trying to sample a color from the UI, the periwinkle blue from the flip horizontal icons, and the color shown by the pop-up color sampler loupe is different than what the color palette reports is the color I just sampled. Check out the screen grab.
  15. ronnyb

    Zoom tool bug

    1. Hold down Zoom Out keyboard equivalent (Cmd + Option + Space Bar) 2. Draw a rectangle with Zoom tool 3. You just zoomed in!
  16. Nothing happens when Advanced... is selected or am I doing something wrong? Suggestion, I'm always Aligning Center AND Aligning Middle, Can we have a selection for both? Like instead of Align Middle maybe Align Yaxis and Align Center maybe Align Xaxis Then Align Zaxis for both... ????? But I definitely use both at the same time.... Maybe there is a trick?? BTW Affinity is the best.... Regards, William
  17. HELLO.I NEED A QUICK HELP EXPORTING MY FILES INTO EPS,PDF,etc.... I MAKE THE DESIGN AND WHEN I EXPORT THE BACKGROUND COLOR CHANGES,AND AFTER SAVING MY FILE IS RESIZED. :mellow: SORRY FOR THE WRONG LANGUAGE I AM NOT EXPERT IN ENGLISH,HOPE YOU UNDERSTAND. :) HERE IS A VIDEO LINK OF MY PROBLEM: https://www.youtube.com/watch?v=3HgDKSuevy8&feature=youtu.be
  18. Hi there - I cannot seem to export to PSD. The file rendered is 3k and just simply doesn't work. Any ideas? (I'm using the Trial version) Best, Justin
  19. Hey, I wanted to open my project I worked on for 3 days, and I get "The file type is not supported"! I tried to also save a new file and open it right after the save - Still, the same thing! Why is this and how can I fix it? Thanks!
  20. MEGraphicDesign

    Color Value Input bug

    Helllo Affinity team, I wanted to make you aware of a slight bug in the color value input panel. When I try to manually input CMYK or any other value types the value adjusts, but like it has a mind of its own....not at all the value I inputted. The value sliders also have a slight issue wanting to jump to its own value input when I try to do it that way. Crazy as it may seem....it doesn't always do this. Help!
  21. Hello, I have exported one of my drawings as an SVG and reopened in Affinity and some of the content does not show. The layers show that they are there but the content is missing. I would like to know if this is only a bug when reopening in Afdesign or does it effect other vector editing programs as well. --Jeremy
  22. Hello, I've found a problem in bounding box calculation for alignment. Version: Affinity Designer 1.1.2 I created two horizontal lines (holding SHIFT key) using "pen tool". Then I created text object. I made a group from one horizontal line and text object. Finally I selected the group and second horizontal line and tried to do horizontal alignment (left, right, space with 0px...). You'll see the horizontal line in the group is ignored for bounding box calculation and group is aligned to text only (see the attachment H_align_left_1.png). Once the horizontal line in the group is rotated or one endpoint is moved vertically so height of the line object is not 0px the alignment starts working correctly (see the attachment H_align_left_2.png) Br Jaroslav
  23. I downloaded the AD trial version onto my Macbook Pro running 10.7.5. I have no trouble running the Adobe CS/CC apps and my machine meets all the minimum requirements for your app. Whenever I try to export any file as an SVG (even just a simple circle or square), nothing is created. No files show up anywhere. Other export methods do work. Then after trying the SVG export, whenever I try to close the file, I get the spinning beach ball and must Force Quit the app. Is this a known bug? Do you have any recommendations? I really wanted to like this app as an alternative to Illustrator but if it's this unstable and unusable, I will need to look elsewhere. Thanks for your time.
  24. Every time i try to use the blur tool it does the exact opposite of blurring. It keeps making the color high in contrast and brighten and show random designs. Either that or it makes a dark line in random spots for no reason
  25. I was mucking around with some layer styles and came across an issue when applying an outline shadow with a circle. It seems the shadow gets cut off at each end/furthest side of the circle. See below: 0.3 px radius - shadow cut off at top 0.5px radius - shadow CUT-OFF at top 5px radius - WORKS FINE.
×