Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Search the Community

Showing results for tags 'anchors'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Affinity Support
    • News and Information
    • Frequently Asked Questions
    • Affinity Support & Questions
    • Feedback & Suggestions
  • Learn and Share
    • Tutorials (Serif and Customer Created Tutorials)
    • Share your work
    • Resources
  • Bug Reporting
    • Report a Bug in Affinity Designer V2
    • Report a Bug in Affinity Photo V2
    • Report a Bug in Affinity Publisher V2
    • Report a Bug in Affinity Version 1 applications
  • Beta Software Forums
    • macOS Beta Forums
    • Windows Beta Forums
    • iPad Beta Forums
    • [ARCHIVE] Reports from Affinity Version 1 Betas

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


MSN


Website URL


Skype


Facebook


Twitter


Location


Interests


Member Title

Found 9 results

  1. I am creating a hyperlinked digital planner with a monthly, weekly and daily view. I want to be able to select a particular day on a monthly calendar (ie January 14) and have it redirect me to that corresponding page (ie January 14 daily view). I've figured out how to populate 12 months, 53 weeks, and 365 daily pages with unique anchors, by using the data merge feature on master pages. The issue I'm running into now is when those anchors populate, they all share the same name as you can see in the image below that I've attached. For example I want to have a unique anchor for the January 1, January 2, January 3 page.... and so on. So I've created a master page with my data merge inputs and added an anchor labeled "January <date> | Daily ". What I was hoping would happen is that when I select "generate" in the data merge window, that it would fill in each unique date but instead what I'm getting is 31 unique anchors to unique pages that are all titled "January <date> | Daily" . This is what the page looks like on the master page before I generate the data merge. I have an anchor on the master page so that when the dates get pushed through, each individual page has a unique anchor with a unique date. This is what it looks like once I generate the data merge. The date is filled in, the unique anchor appears for that particular page, but I get 31 anchors all titled "January <date> | Daily". But what I want is for it to say "January 1 | Daily, January 2 | Daily, January 3 | Daily, January 4 | Daily, January 5 | Daily, ....and so on" without me having to do it manually. *BTW the January 12 | Daily , January 13 | Daily , January 14 | Daily , I manually changed. They all read "January <date> | Daily".
  2. I have recently discovered that one can auto-resize a frame text (box) to "fit" the text within. This seems to be dependent on the starting width of the frame, the starting height of the frame, etc. For example, I can double-click the center anchor ("button") on the right of the Frame. This often resizes the frame and text to "fit" BUT it usually will leave a "margin" on left and right (spacing between the text and the frame edges). As I am trying to move the text box just a certain distance away from another object, I also want the text itself to be in the same position (say, 1/8 inch from the object). When double-clicking the (left or right) center button, my frame text enlarges or shrinks and acquires an "inset" where the text has some space on left and right (not on top or bottom). The Studio Text Frame shows insets set to zero. My text is set to center both vertically and horizontally. The style of the text is controlled by a Text Style entry. The Paragraph section has the Decorations set to "none" - unchecked. It is as though some internal process is attempting to "balance" the text rows to be somewhat even/equal and adding that space around. In some cases where paragraphs are longer (more rows of text), the bottom-most row will often be shorter than the ones above. This makes the paragraph "stand out" and look a bit neater, but is a mystery how I can control that process. It it notable that a brand new document with a new Frame Text - does not exhibit this "problem". I have searched extensively but have not found the cause of this behaviour. I cannot find any tutorial material in the help sections of Affinity and I am hoping there is one out there to be seen. Example text included as screen shots. Text is centered horizontally and vertically. First one is how I want the box sized. The second one is after I double-click the right, center button - the text gets some unwanted space on left and right. This double-clicking also has other qualities, such as moving the right or left edge clicked to center and space the text. So click the right edge center button and only the right edge moves; click the left and only the left edge moves; you can also click top center or bottom center edge buttons and the Frame Text will shrink to allow the text to just fit Thanks for any insight you might have.
  3. I'm having several issues with anchors preventing me from being able to export them as bookmarks. 1. Creating anchors from Table of Contents populates the anchors, but they are in the wrong order. The order doesn't match the Table of Contents and is also creating anchors for random paragraphs that are not in the Table of Contents. I deleted every anchor individually (you can't delete them all at once?!) and re-created the anchors from the TOC with the same results. 2. I can't move anchors to a new position. It will let me move an anchor as a new child, but the "line" never shows up to just change position, only the highlight for child creation. 3. Even if I could move anchors to a new position, it won't scroll up or down to get to a new spot in a long list of anchors. 4. Attempting to move anchors too often leads to the program crashing. Starting with a brand new Letter sized document, I create a textbox on each of the three pages and place "Page 1" in the first, "Page 2" in the second, and "Page 3" in the third. I then highlight each piece of text to create three anchors: Page 1, Page 2, Page 3. Trying to drag the Page 2 anchor to a new spot crashes the program every time. Lenovo Thinkpad, 64 bit OS, Windows 10 Pro, Affinity Publisher Version 1.9.1.979
  4. Just installed Publisher 1.9.0 What have you done to the anchors/hyperlinks? Document I am working on all anchors work as expected - contents page takes to where I want - that was in 1.8.4. Now with 1.9.0 I highlight a word and select anchor - add that to the contents page and when I try "go the hyperlink page", I get the wrong one. Further when I check the hyperlink on my contents page the anchor has changed to some other already used anchor. I can not get anywhere with correcting this. Help please. Steve "Ed"
  5. Hello all: I'm putting together a cookbook with lots of recipes. I'm having an issue with the table of contents. In the process of finishing this book, I've made tweaks that impact the table of contents. Every time I refresh the toc, all of my hyperlinks to my anchors disappear and I'm back to square one formatting over 300 recipes again and again. This is incredibly frustrating and time consuming. Am I doing something wrong? It would be so much easier if I knew enough to write a macro that would automate the steps for each recipe. Is there a way to refresh the toc so that I don't have to go through this process for every minor change?
  6. Hello, I have a file with about 200 pages and over 3,000 hyperlinks. I have set the hyperlinks to anchors in the document. Now editing in the document is hardly possible anymore, because every action is executed very slowly. Since I want to add more pages with links, someone can give me a hint why the program gets slower and slower.
  7. Hi, I am fairly new to Publisher and I'm creating a digital planner. I am using hyperlinks/anchors to link menu "buttons" to page content, but only the source links on my master pages display in the hyperlink studio, not their target anchors, despite being separately named elements. Surely both hyperlink sources and target anchors should be showing in the studio? I've selected show all types, show anchors etc. am I missing something here? Yes, I can click each source hyperlink and "go to target" but it would be easier to have targets listed in the studio too, especially for tasks like bulk-renaming. For example: If I want to rename the source hyperlink, the studio displays them in a list and i can click to rename each one quickly without leaving whatever page I am on in the document; but to rename the target anchors I have to click "go to target" for each source, which takes me to the page, right click on the anchor and then click "Interactive>anchor properties" to rename it. Seems unnecessary when there's a studio called Hyperlinks they could be appearing in?
  8. I am on the hunt for the best vector freehand-sketching tool with a high degree of input precision. I really want Affinity to be that for me, except I can't seem to find how to adjust the number of control points rendered for each stroke. What currently happens is that, despite stabilizer turned off, my lines are being too "simplified." For example, I do a lot of zigzag hatching in my work, which have very tight direction changes. After I release and the stroke is created, those acute angles kind of "bubble out" because AD is simplifying/smoothing my stroke into fewer points than I would like. Is there a way to change this, somehow? Thanks.
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.