Jump to content

Search the Community

Showing results for tags 'afp-2709'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Affinity Support
    • News and Information
    • Frequently Asked Questions
    • Affinity Support & Questions
    • Feedback & Suggestions
  • Learn and Share
    • Tutorials (Serif and Customer Created Tutorials)
    • Share your work
    • Resources
  • Bug Reporting
    • V2 Bugs found on macOS
    • V2 Bugs found on Windows
    • V2 Bugs found on iPad
    • Reports of Bugs in Affinity Version 1 applications
  • Beta Software Forums
    • 2.1 New Features and Improvements
    • Other New Bugs and Issues in the Betas
    • Beta Software Program Members Area
    • [ARCHIVE] Reports from earlier Affinity betas

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


MSN


Website URL


Skype


Facebook


Twitter


Location


Interests


Member Title

Found 3 results

  1. Exporting a small (16x16) tga file, results in the file getting saved upside down. You can even see in the export preview that it's upside down. This is super bizarre to me, and suddenly I feel uneasy about having edited so many files with affinity recently, although it definitely doesn't always happen, since I would have noticed. Not sure what is special about this file. To repro, open the test.tga file, then just export as tga and hit preview. I'm using Affinity Photo 1.10.4.1198 on Windows 10. test.tga
  2. While making textures intended for a game engine I discovered a weird issue: when I export TGA files for some reason their bottom right corner pixel gets inverted. If I export the same image to PNG or JPG there are no issues at all. I'm attaching original .afphoto file as well as TGA and an upscaled PNG file converted from TGA for better view. To reproduce this bug simply create a project and export it as TGA. You should notice exactly one pixel being inverted in the bottom right corner. I'm using Affinity Photo 1.8.5.703 T_ConcreteWall06.afphoto T_ConcreteWall06.tga
  3. TLDR: When exporting to TGA(Targa) format UpperRight and LowerRight corners have their Red and Blue channels swapped. Steps to reproduce: 1) Create any document. 2) Place in UpperRight or LowerRight corner object with color that has different Red and Blue channels. eg. R:125 G:00 B:00 3) Export image as TGA(Targa) 4) Load exported TGA image to AffinityDesigner. Actual result: One pixel in both right corners has Red and Blue components swapped. If we saved this color in one of corners: (R:125 G:00 B:00) the loaded pixel in that corner will be: (R:00 G:00 B:125) Expected result: components are not swapped during export. Especialy useful if you are writing TGA loaders/converters and you are expecting that data you are loading is correct... Additional info: I have not experienced any problems with Green or Alpha chanel so it seems to be affecting only Red and Blue.' Export size seems to not have affect it's always one pixel from both corners. It's not loading problem. After checking TGA files with Hex editors and checking values stored inside the incorrect values are saved during export. Files to reproduce and screenshots are attatched: 2 .afdesign files with sources that can be used to export check source files. 3 Exported TGA images where inproper behaviour can be spotted 3 Screenshots from symetric gradient presenting incorrect data after export. 4x4.tga TGABug.afdesign 4x4GreenEdition.tga TGAGradientBug.afdesign TGAGradientBugBig.tga
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.