Jump to content

Search the Community

Showing results for tags 'Transparency'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Affinity Support
    • News and Information
    • Affinity Support & Questions
    • Feature Requests & Suggestions
  • Learn and Share
    • Tutorials (Serif and Customer Created Tutorials)
    • Share your work
    • Resources
  • Bug Reporting
    • Report a Bug in Affinity Designer
    • Report a Bug in Affinity Photo
    • Report a Bug in Affinity Publisher
    • (Pre 1.7) Affinity Range Bugs Forums
  • Beta Software Forums
    • Affinity Designer Beta Forums
    • Affinity Photo Beta Forums
    • Affinity Publisher Beta Forums

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 138 results

  1. Maybe I just missed something, but maybe this is a bug. I drew some objects using the Pen Tool in Polygon mode, then I grouped them and copied and pasted the result into a DrawPlus document because Affinity Designer was not showing all of my installed fonts (That topic is posted under a different thread). The pasted group did not have a transparent background, even though there is no reason I can see for this to have occurred. The pasted object had a rectangular white background the same size and shape as the lines indicating the grouping. On the other hand, when I exported the group as a PNG directly form Affinity, the background WAS transparent. Thanks for helping.
  2. I want to change the colour of an object with a transparent background (.png). it's easy to do in Photoshop - click the protect transparency icon on the layers panel. And it's easy to in DrawPlus X8 - select the object - the transparent areas are automatically protected. I could make a selection of the object in AD however that imo is not a solution - an object like an intricate Celtic knot pattern on a transparent background for example. Or, am I missing something here and there is a way to protect transparency in AD? Edit - found it - the flood fill tool. I am a bit baffled though transparency is not protected with the brush tools (both personas).
  3. Hi Beginner question (searching the forum didn't help): In AP, Filters - Colours - Erase White Paper is super easy - but after exporting as jpeg the background is white again, not transparent. Which step am I missing?
  4. Well, duh! I was watching Affinity Designer tutorials this morning, something I must make more time for, and discovered the Transparency Tool with balloons tutorial. And there is the solution to my problem of not being able to feather the edges of photos to blend in with color-matched backgrounds. Once I get skilled with this tool, it will give me far more control than Illustrator's simple edge-feathering tool has. But the Elliptical type doesn't quite work the way I'd like it to, being that I often need to feather the edges of square or rectangular shapes. Linear works well, but then I have to make a copy of the photo for each edge I need to feather (usually two) and manipulate further in what should be a one-stop process. It seems to me that a logical place to add a feathering-type effect would be here to allow for both vertical and horizontal adjustment on a square or rectangular shape. Something like the Elliptical type but more squarish. Or maybe there is a way to adjust the Elliptical type to make it more squarish? I'll keep playing, but I wanted to let you know that this was a real relief to me to discover. Thanks, folks!
  5. I converted a photo into a silhouette and traced it in order to print on a T-shirt (bitmap to vector with transparent background). However, I need to remove a gap between the arm and the body and am stuck. There is no knife ala what I vaguely remember from Illustrator (I'm a photo guy not a designer ;) ). i selected the area with a pen, but can only fill it with white to cover the black, which won't work for printing. "Cut" is greyed out. How do I delete this space inside the trace of the image? Alternatively, since I traced the silhouette and filled with the entire outline with black, if I could have traced the outside, then traced the inside without deleting the first pen selection, I'd have it done. But I couldn't find a way to combine two pen selections on one layer. Thank you in advance anyone. / jim bit map: https://flic.kr/p/He7ywE
  6. Hello, Please find the attached document, AD screenshot, and PDF export. The shadow around the graduation cap (and in other places) is not correctly exported. Commencement Invitation Card.pdf Commencement Invitation.afdesign
  7. I'm continuing to struggle with Affinity Photo's channels and alphas. I need to be able to assign an alpha to my image while retaining the underlying color data of the transparent area. With photo it appears that the only way to get an alpha channel is to leave portions of my image transparent which results in loss of color data in the Red, Green and Blue channels. So all transparent pixels end up being black, this causes ugly halo effects on textures loaded in 3D applications. The Composite Alpha is just created from each layers alpha. I need to be able to apply a master alpha to the image. Is this at all posible?
  8. Hi, try as I might, I can export a slice as a .png with transparency. I've tried with an artboard and without, no luck. I've searched this forum and the www. What I'm I doing wrong?! Thanks in advance.
  9. Hi there, I noticed a potential problem with (premultiplied?) alpha/ transparency in some TIFF files. For example loading "Install OS X El Capitan.app/Contents/Resources/ProductPageIcon_512x512.tiff" (Sorry, I can't attach the original file to this report for obvious copyright reasons ;) ) shows the typical and unwanted black halo pixel effect in Affinity Photo. OS X's own Preview.app displays the very same file properly, see attached screenshot. I'm not entirely sure this is a bug in Affinity or not. In case it isn't I would appreciate a tip how to fix this problem when it happens. :)
  10. When I create a polygon with some opacity or gradient and try to use it as a container when I paste inside a polygon or image it does not work. I need to create 2 polygons: One for transparency and other as a container.
  11. Hi, I frequently need to create fairly light coloured designs, and that is a royal pain* on a transparent or white background, especially if parts of what I do need transparency. At present I draw a page-size box, colour it and lock it in the background (to stop it from being selected), but this feels a kludge - did I miss something? Is there an alternative to "white" for a non-transparent background? Is there a way in which I can set an alternative colour for the drawing background? Even just changing the grey boxes in the white-and-grey boxes that represent a transparent background would be a help. The idea is thus to define an alternative for what remains transparent in export. Cheers, P * presidential pain for nations without royalty :)
  12. Hello, For the uploaded .afdesign file, selecting the first group of curves and exporting without the background results in this incorrectly-rendered PNG. It looks almost like it was exported as an 8-bit instead of 24-bit PNG. Oddly-enough, exporting the entire document results in the correct, perfectly-transparent background in the final results. Thanks. Untitled 2.afdesign
  13. Dear affinity designers, first of all congratulations to your product. It is definitely a kick-ass alternative to ai and makes my current efforts to layout and polish figures for my Master's Thesis really fun. There is one issue however that I don't understand. It has happened twice to me now. I don't really know whether it's a bug or whether I did something wrong, but as I really don't know what I could be doing wrong here, I thought it would fit in this bug category. I'd of course be really happy to find out I just did something wrong that can easily be corrected. The first case (see figure1) is a big file with lots of plots imported from matlab. They were saved as .pdf there, one big multiplot figure and two subplots were imported from other figures. Within affinity designer, everything looked great, but then, when I exported the finished thing as pdf, a little bit of the axis labels got half transparent. This did not happen when I exported as a png. https://www.dropbox.com/s/wlz74jqrghia6hi/figure1.png?dl=0 The second case is the other way around: I produced a figure in affinity designer that included transparent, coloured circles. I copied them several times and put outlines around some of them (sometimes using the cool "Montage" function), and for a reason I don't know their transparency is gone in an exported pdf but not in an exported png and not within affinity designer. And this only happens for some (two to be specific) of my 9 grouped venn diagramms. Really puzzling. https://www.dropbox.com/s/gwsehgb85rsabnn/figure2.png?dl=0 Edit: Using Mozilla firefox I can't upload files ... hope the links to dropbox work. Many cheers, Christoph
  14. As nice as things like live preview of layer blend modes are (and they are!) I can't help feeling a bit short changed by the layer transparency slider....? Anyone else feel like this? I'd really like a live preview of the layer's transparency as I drag the slider, but I have to let go and test it each time. I would say something like 'oh, I understand, it must be difficult to do...etc', but actually, can it really be that hard to make the transparency live? Or at least catch up, if you hold at a point, could it at least catch up to that point when it can manage it? While we're here, I find hue changes similarly frustrating - they do catch up, but I do think it feels a bit slow....anyone else?] Cheers Wayne
  15. Attempted to blend an imported photo into a black background using the transparency tool, something I've done many times in the past, but this isn't working in version 1.4. Anyone else? Any solutions?
  16. To reproduce: 1. In AP, add a mask to a light-colored JPG so it has transparent edges. Save as an AP doc. 2. Drag the AP doc's Finder icon onto a dark-colored AD doc. Result: AP doc appears as an embedded doc in the AD doc. It is bordered by a thin light-colored line. The border hairline is actually the color of the original image behind the mask. The border line remains despite zooming or resizing, and appears in exported JPGs. Work-around: Apply a rectangular vector mask to the embedded AP doc, inset just slightly from the object's edges. Designer: 1.4 Photo: 1.4 Mac OS: 10.11.2 Apart from this, wonderful software! Thanks for looking into this, Craig.
  17. Hi guys, I want to export a print ready PDF where parts of the design are transparent and other parts are solid. What happens is that suddenly every element has a transparency. I don’t know why, In the meantime I tried different options – creating a new document from scratch w & w/ artboards, changing the colour, changing the layer/element opacity instead of the colour opacity, converting the text into paths (which sometimes work, but overlapping digits result in some strange boolean effects). I recorded a shot clip trying to show what’s going on. https://youtu.be/KfBph_Q0k8w Any ideas what else could cause this? Is it the colour-format? Cheers Dennis
  18. I'm new to Affinity Designer (AD), and to vector graphics, so pls bear with me. Amazing piece of software, by the way! So, I created a vector graphic with AD (v1.3.5) that is to serve as a logo. The client wanted a grunge effect on one part of the graphic, which I did by adding vector grunge textures as layers. Long story short, I needed quite a few to get the exact effect we wanted. They were mostly laid over text. When I come to export, so the client can use the logo in the real world (i.e., .eps, .svg, and via Illustrator to .ai), everything works fine when I have a background present in the graphic. But I'm trying to find a way to have a transparent version, too. This would be important for the client, in terms of flexibility of use of the logo. Some images that relate to my query: https://cldup.com/T__1kSZ5pa-3000x3000.jpeg I'm having problems with the grunge texture layers. The Erase option on layers or groups in AD is fabulous. It does exactly what I want. I want to get rid of the colored font, but keep the grunge effect over the font (and elsewhere in this part of the graphic). With Erase enabled in AD on particular layers or groups, when you scale up the graphic in you see precise vector shapes are preserved. But when it comes to exporting, there are two options, as we know: 1. Export with rasterising "unsupported effects" (which sadly includes the Erase function); or 2. Don't rasterise, and see the Erase effect lost, and hence the transparency I need lost. In my specific situation, rasterisation is not possible, and the result from Option #1 above is pixelated anyway, which is useless for me. On the other hand, because of the grunge effects, there are literally way too many small shapes to locate and make transparent manually. There are probably 5000+ of these tiny shapes. And I'd not only need to delete what is otherwise a white fill (absent the Erase function), but also the same shape, in place, in the background layers the grunge effects rest on top of. Erase just does this directly. But it's unusable if you need a 100% vector output. Because it is an unsupported effect. I've tried seeking a solution outside of AD. In Illustrator, in iDraw / Graphic, and also Inkspace. In none was I able to work out how to do what I wanted to do. I also tried exporting my AD graphic as .png and running through Vector Magic on the most detailed settings and vectorising again. But the result is at least 50% or more poorer than the original in my AD document. In Illustrator, I could pick all layers with a certain color. But I wasn't able to work out how "cut" those layers *and* all other layers relevant that these shapes or nodes lay over. I also tried merging to get one "flat" layer, but this didn't work as I expected. I still had around 15 layers, which was better than earlier. I had hope to produce one layer, basically black and white, and then render everything white transparent. But this was not working. I was unable to pick a white node without picking everything at the same time, including black. In Inkspace, the exported .eps was pixelated, even without rasterising. I couldn't immediately see anything in iDraw / Graphic that would help, though the .eps file was clean, just like it is in the original AD file. I couldn't see how to erase, in iDraw / Graphic, globally a single hex color, which is really -- ultimately -- what I need to do. Or otherwise, to force that color to be transparent, from the top of the layer tree to the bottom. So: two questions 1. Is AD close to being able to export a vector with the Erase effect preserved? 2. Does anyone have advice on how to get that effect in a complex vector in the meantime, even if outside of AD (in Illustrator, for example)? I spent all day trying to search for solutions on Google, but I'm not finding what I need so far. I fear that the complexity of the layers I have will prevent a simple solution. Again: Erase does it. But it's not possible, sadly, to output a 100% vector from it. Vector Magic has a great feature when vectorising a bitmap image: you can cut a background out with the press of a button. Given the complexity of the grunge effects, this would not exactly be practical in my instance, but I know the hex value that I want to make transparent throughout my graphic, if anyone knows a way of forcing that. Thanks for reading this far ... and for any advice or input.
  19. Hi there! I have a problem with transparent groups. They are getting rasterized when after exporting to PDF. Screenshot from Affinity: https://dl.dropboxusercontent.com/u/29112876/Screenshot%202015-10-15%2011.08.36.png Screenshot of the generated PDF: https://dl.dropboxusercontent.com/u/29112876/Screenshot%202015-10-15%2011.12.02.png Left set of shapes (rasterized in PDF) created by applying transparency on the group. Right set of shapes - transparency applied to the shape layers. https://dl.dropboxusercontent.com/u/29112876/Screenshot%202015-10-15%2011.16.07.png Pdf and affinity files are attached as well. Is there any way to make PDF not to rasterize transparent groups? Thanks! background.pdf background.afdesign
  20. I'm in the process of evaluating Affinity Designer as a tool for combining multiple versions of the same photograph into a single deep image. I've been using this technique for several years using a combination of several applications, and I'm hoping AD may make the step of "squishing" all of these photos together a bit easier. As I am brand new to AD, I'm running into a problem working with multiple layers that I'm currently attributing to the ignorance associated with pilot error. :-) I'm working with 20mp images and lay down the first 5,472 x 3,648 TIFF image in the background layer. This image is basically full frame with no transparency. I then drop in the second image, which is also 5,472 x 3,648, but this image contains only those items which are in focus for that layer — so much of the TIFF is transparent, with the edges around the opaque objects feathered to be gradually blended into the background image. The net effect is to overlay objects in the background, with those in this second layer. (As a side note, this TIFF with transparency is created using Apple's Aperture and Lemke Software's GraphicConverter). However, when I drop the second image into Affinity Designer, the feathered edges that are supposed to blend into the background appear as very prominent gray lines when Opacity is set to 100% and the blending mode is set to Normal. This is different than what I see in other apps, so I'm sure I'm missing something when adding layers in AD. I've attached three image to illustrate what I'm seeing. The first shows a portion of a TIFF with transparency where the edges of the devil figure are feathered into the transparent background. The second shows how this same cropped image appears in AD, and the third is the result of laying this layer over the background, where what should be a completely undetectable transition is very obvious. Layer (in Preview).tiff Layer (in AD).tiff Combined Layers.tiff As I said, this works as I would expect in other apps, so I'm curious about what I'm doing wrong within Affinity Designer. Thanks!!
  21. Hi, How do I export an 8 bit png with transparency in Affinity Photo? I keep getting a semi-transparent blue background. Mike
  22. Hello All... New member here. Experienced PS user... I am sturggling with creating a web graphic with a transparent background. I feel it's something simple I am just missing but I've searched other threads and most address issues in AD but this is in AP. What am I missing? The export doesn't have a "save for web" or a transparency checkbox. When I select the image and choose "save selection without background" in the export I still get a white box when placed on a web page. I'm used to this being a simple PNG save in PS, so I'm not seeing it. Thanks for any help.
  23. After working on a document with lots of layers for a while, I found out that there's no way to change the background colour of the document from white to transparent, or at least, not an easy and intuitive way... someone in the forum mentioned the menu File > Document Setup but I can't find it under the File menu. I need to set a transparent background in order to export a PNG with transparency. Creating a new document with transparent background doesn't seem to help unless you are willing to loose all your layers and flatten them all into a single layer. Far from ideal! I am surprised such a basic feature seems to be impossible to achieve. I am also surprised that there's no way to contact the customer support directly, I'd be willing to pay a bit more but get the support that I need. Thanks
  24. Why aren't my exported tiff files not supporting transparency?
  25. Good day to everyone, I have started to use Affinity Photo a few days ago. I am curently working on a project where I need to place some objects without background. Affinity Photo works good so far (concerning selection tools). But I have an issue with export. Tiff doesn't work at all. PSD has "sketchy" edges. Only PNG works, but pictures are supposed to be printed. What shall I do? Please, see attached picture. Thanks Jan
×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.