Jump to content

wigglepixel

Members
  • Content count

    122
  • Joined

  • Last visited

Everything posted by wigglepixel

  1. Interested in computers, graphics, animations, games, vr, interactives and internet? Computer graphics, animations and interactions are now self-evident. You just have to pick up your smartphone, tablet, desktop computer or what else and you feel intuitively when you have to swipe, click, drag or pinch zoom. You also expect nothing less than nice interfaces with smooth animations. But it wasn't always like this... There were times where there were no editors like Photo and Designer, nor Illustrator, nor Photoshop, and even computers and animations of frames didn't exist... I wrote a blog series of six where I like to take you on a journey through time with our focus on learning about the development before and during the creation of computers, digital graphics, animations, graphical interfaces, graphics software, interactivity, 3D, a pinch of the first games, the creation of the internet and a touch of virtual reality. I have made more than 110 illustrations for this series with Affinity Designer and also provide each part with at least one interactive to bring the events alive as good as possible for you. Part 1 is out there now! Hope you like it and I'm sure you learn something new from it and be surprised by some events! There will be a new part every month from now. Enjoy! English: History Interactive Computer Graphics - Part 1 Dutch: Geschiedenis Interactieve Computergraphics - Deel 1
  2. Well, it's been a while, I've been very busy last months and I take writing blogs seriously and like to serve quality content. So sorry you had to wait sooo long, but the second part of the series will go live soon! ...And there will be a little oldfashioned GAME inside! (and it's not or ) @Alfred @Madame @Roger C @GarryP @Wosven @A_B_C @WatcherMagic
  3. After setting up a keyboard shortcut by hitting the a numerical key on the top of a standard querty keyboard in the keyboard shortcuts settings panel, both the numericalkey as well as the numpadkey representing the same number trigger this new shortcut. For example, pressing the '1'-key on the top of the keyboard together with alt to assign a shortcut results in the same keystroke as pressing the 'numpad1'-key together with the same alt-key. This is not what I would expect, because these are two different keys with no technical connection. Treating both keys as the same limits the amount of keystrokes we can assign. It's also errorprone, because we don't expect the alt+'numpad1' to trigger an action we assigned the alt+'1' (1 on the top of the keyboard). So it seems like Affinity doesn't store the key-code, but the key-value to bind a keyboard shortcut. But it should store the key-code instead to assign the right key only. [edit] Another problem caused by this is what I'm facing right now: I have a rotation assigned to Alt+2 (addressing the regular '2' key on the top of the keyboard). But when I'm in a textframe and want to enter a special character by using an alt code sequence (so while holding Alt hitting a code-sequence like numpad-0, numpad-2, numpad-3, numpad-3 to have a 'é'-symbol) the alt-way to enter a symbol doesn't work anymore AND the canvas will rotate. And that's obviously not what should happen here. I wouldn't be surprised if there's a connection between this one and the no-difference-between-alt-keys Issue I reported earlier. Maybe the same solution could fix both? That would be nice! Thanks in advance!
  4. During configuration of shortcuts to use a Wacom dial to rotate canvas I found this issue: * In the settings shortcuts panel both left and right Alt-keys on the keyboard are displayed as 'Alt', so there is no way to see the difference between the two * But the actual keyboard shortcut is in reality indeed bound to the left OR the right Alt key. Looking in the interface it looks like both 'Rotate Left' and 'Rotate Right' are bound to the same shortcut (Alt+2), but in fact the first one is bound to AltLeft-2 and the second to AltRight+2. Affinity Photo knows this, because it doesn't show warning symbols to indicate a keyboard shortcut is already in use (it shows the regular clear-buttons): This is confusing and error-prone. It would be better if the interface shows AltRight and AltLeft instead for the alt-keys OR the software should treat both ALT-keys as the same (which I personally prefer and would expect). (I posted this in the Photo AND Publisher beta bug forums too, because it's happening in all three programs. It's probably the same codebase, but just to be sure posted this in all three forums)
  5. Seriously? This is no hardware issue and has nothing to do with the keyboard hardware nor driver. We can tell, because we can see clearly in the interface that Affinity knows the difference between the left and right alt (it's not showing a warning symbol when we use different alt keys), but just doesn't show the right name for the key (leftAlt / rightAlt (or AltGr)). It's obviously happening on several totally different windows machines (I alone saw it on all three systems I work on, which are totally different both in hardware, age, as in configuration, and it's also confirmed by @walt.farrell as you could've read here). This is clearly a problem in the Affinity software, so I'm very surprised by your reactions (and that you didn't remove the [fixed] from the title). Could it be you perhaps misunderstood my post? Could you please post a video to show us it's working on a genuine Windows machine (so no Virtual Machine, or the Mac-configuration you were talking about before, but a PC (no Mac) with Windows)?
  6. Gabriel, the brand or model of the keyboard is irrelevant information to solve this issue. Like I wrote in the opening post Affinity already knows which alt is pressed. This has nothing to do with hardware. It's just the Affinity software not showing the right label-texts. And that's certainly an easy thing to fix for a developer by just looking at the codebase alone. Maybe you could remove the [fixed] label in the title, because it's obviously not fixed yet.
  7. wigglepixel

    [AD] [AP] Misc illustrations

    These animal-cars are great! Great idea!
  8. I just used the website gridcalculator.dk to create a design grid and export it to AI to open in Designer (or Photo). But when opening the created file Affinity immediately crashes and directly closes the software. Not sure what's wrong here, if it's a problem inside the AI-file or something Designer doesn't like inside the file. Can't see if this file works within Illustrator. And I obviously cannot view the file in Designer to see what's wrong, because the software kills itself on opening. But at least Designer is not suppose to crash on opening a file. Here is the link with my exact settings: http://gridcalculator.dk/#/1080/12/20/20 . The AI is in the attachment. grid.ai
  9. Thanks for your confirmation and try to help @adi. I understand it's easy to setup a document with a grid indeed, but found that site and just tested it out for fun and than found this bug so reported it. Could be a nice online tool to create a grid file though, well, if it worked
  10. Hi @GabrielM, I don't see any change 1.7.1.404 (the latest version AFAIK). Still both Alt-keys ('Alt'(left) and 'Alt Gr' (right) ) are shown in the settings as just 'Alt', so we still can't see the difference between the two. Or is there a newer version of 1.7.1 perhaps with this fixed?
  11. Thanks for your reply @Old Bruce. I don't have Character styles applied to those parts so I can keep Characters styles for things like 'Strong' and 'Hyperlink' inside. I know about the toggle to turn on or off spelling check, but it turns it off for every frame, and I'd like to keep some frames (the content text) checking. Thanks for doing that experiment @walt.farrell. I just tried it again in a new file, exactly as I did it yesterady, and it works exactly as expected now. Not sure why. So I opened the file I worked on yesterday again now and without changing a thing it works with that file too now: no more red stripes under the parts where I switched the language to 'none'. And also if I now change other paragraph styles to language 'none' the red lines disappear as expected. That's odd. Because yesterday the red underlining wouldn't go away whatever I did and they were there when I left the file. Yesterday I did some things to hopefully refresh the interface (to update the lines to dissapear). Even closed Publisher and opened it up again in the hope to refresh the spelling lines, but even that didn't work. The red lines stayed. But today suddenly the red lines are gone while just opening the file... not sure why. Feels like a refresh-thing. I'll keep an eye on it. Thanks for your help guys!
  12. I'd like to disable the Publisher spell checker on some textfields with addresses and stuff like that, while leaving the spelling check on for fields like the body of the letter. So I put the Dutch language in the base style and all the substyles to inherit that base-style. In the paragraph styles I use in fields where I don't want the spellchecker to work I set the language to 'none' to turn off the spelling check. But to my surprise, eventhough Affinity doesn't have a language anymore to check on, still it shows red understripes on those fields to indicate language mistakes. So it could be that it now marks everyword as not being right. Now I'm not sure if it's impossible to turn off spelling for a paragraph style or that maybe this is a bug I'm facing here, or perhaps I am missing something here. Anybody here perhaps knows if there is a way to disable spell checker in a paragraph style? (I don't have a character style applied on top btw)
  13. Ah I see. I didn't know about that. Thanks for the quick reaction and pointing me in the right direction to learn more about those styles. Thought I knew enough about these styles now, but guess I haven't seen it all.
  14. Somehow I got a double [No Style] in the Text Styles panel. Not sure how it got there, but no matter what I do, can't get rid of it and the extra [No Style]-'style' keeps selected. Tried deleting, deselecting, selecting other objects, removing all characters from the selected textframe... nothing makes this thing dissapear. There's no 'delete' in the rightclick-contextmenu on this thing either. Looks like a bug to me. double-no-style.mp4
  15. wigglepixel

    German Translation for margins

    Ah, you're right, now I see he's using facing pages indeed. Guess I should've looked deeper as a newbie in Publisher
  16. wigglepixel

    Files size afpub & PDF

    Do you perhaps have 'Save History With Document' enabled in your File-menu (see screenshot below):
  17. wigglepixel

    German Translation for margins

    Me neither; See screenshots below: Left = Links, Right = Rechts, Top = Oben, Bottom = Unten. All seem right to me. Don't know how you got those 'Innen' 'Aussen' text-labels, I don't see them here. Nothing wrong here in Publisher 1.7.1.404 And this is what I see when I switch PUblisher to German: There IS a Links and Rechts (see above screensot). But for some odd reason his screenshot says 'Innen' and 'Aussen' instead of 'Links' and 'Rechts'. His border isn't 0 mm, the numbers are covered by his painting
  18. Hi, I added the Dutch language dictionary from https://github.com/LibreOffice/dictionaries to the dictionaries folder. With help from the thread below about the right location and folder-name (the folder shouldn't be called nl_NL, but nl-NL), I see the Dutch language appearing now in the dropdowns in Publisher's settings (like in the AUto-Correct panel). But I can't find some way in the interface to actually switch the spell-checker-language to this newly installed Dutch language-dictionary. I would expect this to be somewhere in the preferences or in the Spelling options, or else somewhere in the Text-menu or maybe even the Paragraph panel, but can't find it anywhere. Also searched the help on language and spelling, but no satisfying results there either. I might be missing something here.. Where can we switch the current language of the spell checker in Publisher to another language? (and where in Photo and Designer?)
  19. Ah, now I get it! Thanks! So the spelling language could actually be set to the base style once per document so we have the same language throughout the whole document. Except for when we change a style to not inherit that language from the base style, but set to a different language for that style. And when we have set a style to a textframe, or only to one or more characters, words or lines inside it, even then, we can still override the spelling language in the Character-tab for only a selection of text! So if we have a textframe full of Dutch text we are still able to select a word or a line and put that piece to be spelling-checked in Spanish... So if I would like to create some textframes and have them all on Dutch spelling check, I just change the language of the base style to Dutch and make sure at least some style is selected when creating the textframes (like the 'Body'-style) and everything is checked in Dutch. And if I would like to have a different body styling per textframe I would just copy the Body-style to a new style and even that style still has dutch as a language, because it's still inheriting from the base-style, which is set to Dutch. Wow! That's actually very powerfull! I like it! Thanks for your help!
  20. Thanks for your reaction. Not sure if I get this right; do you mean we have to set the interface language of Publisher or the Windows interface language to Dutch, just to have default Dutch spell checking inside Publisher? I hope not. That's not what I want. I always have all interfaces in English and that's for a purpose: next to me liking English better for interfaces (technical stuff, programming languages, tools, comments in code etc.) and do everything in English (so recognise all terms in English), there's way more information about everything in English to be found on internet than Dutch. So I don't want to switch my interfaces to dutch. But I want to have Dutch, but also other languages (like English and Spanish and maybe German) to spell check. Or is there a general default language setting somewhere you mean here?
  21. OMG found it; it's in the character-panel... that was the last place where I would expect a language setting, but maybe that will make sense to me later? At least I found it and it works!
×