Jump to content

20legend

Members
  • Content count

    1
  • Joined

  • Last visited

  1. 20legend

    iPad or Not

    My iPad only supports IOS 10 and as Affinity requires version 11 I can use use the iPad version. :-(
×