Jump to content

Dampsquid

Members
  • Content Count

    22
  • Joined

  • Last visited

Everything posted by Dampsquid

  1. Hi Guys Zipped PNGs attached. @Chris B which stock file(s) are you referring to? Happy to try a few times (reminder: doesn't crash every attempt). two png files.zip
  2. Hi Chris Attached a couple for you... as you'll see, small
  3. Nope. I simply open the PNG, manually crop around the image, and apply via the button or pressing enter - doesn't matter which, and the crash occurs.
  4. I opened a bunch of PNG files, all simple, small. Planned to crop, export, close, each in turn. First one, no problem. Second one: as soon as I applied the crop Photo crashed. Mac OS offered to reopen Photo, I accepted. [New] first file, no problem, second, crash as before. This pattern repeated until I'd managed to complete my overall task. I don't know what's going on, but this seems to me very similar to the crashes experienced when resizing canvas, reported recently. Affinity Photo_2019-07-12-104900_Porter-McBook.crash Affinity Photo_2019-07-12-104801_Porter-McBook.crash Affinity Photo_2019-07-12-104704_Porter-McBook.crash Affinity Photo_2019-07-12-104611_Porter-McBook.crash Affinity Photo_2019-07-12-104433_Porter-McBook.crash Affinity Photo_2019-07-12-104330_Porter-McBook.crash
  5. Followed instructions. Ran perhaps 12-15 attempts, two crashes. So it seems the answer is 'yes, but less often'. Not very definitive, but as you can imagine repeatedly running this is time consuming and somewhat boring :-/. I should probably go and do some revenue generating work now... :-D
  6. Hi MEB I'm not getting a crash window... When I click 'resize' the app window vanishes, nothing else appears. On restarting Photo, it's as if nothing had happened, I get the usual splash screen, and that's it... I did find the attached in ~/Library/Logs/DiagnosticReports. Hope that's the same thing? I can't answer whether it's since the last update definitively. I have had Photo since pretty much it's initial release - I have not had this issue previously, but I don't use Photo daily. Affinity Photo_2019-07-08-123424_Porter-McBook.crash Affinity Photo_2019-07-08-125010_Porter-McBook.crash
  7. Doesn't happen every time, roughly 1/3 to 1/2 the time... Doc is JPG 1920x1080. Resize canvas in proportion to 1238 pixels high, anchor center. Bam! MacBook Pro 2018, 10.14.5, Photo 1.7.1. Nothing too weird hardware wise, Thunderbolt dock feeding a few things inc. external widescreen monitor. Edit: actually you can have a file this is happening with, just uploaded. First time I edited this particular file it caused the crash. Subsequent attempt worked. Just tried it again for shits & giggles, first time caused the crash again, second time it worked OK.
  8. Graphic heavy? Yes, very. Old computer... well, it's not too old - a 2015 MacBook Pro, usually up for just about anything. Final export completed successfully, but it took around 2 hours.
  9. Painfully... 236 page document, been exporting now for 50 minutes, shows around 2/3 complete. :-/
  10. @sean Thanks for the detailed reply! At least now I understand what's going on. Of all the very many things I tried, having the two curves drawn in opposite directions wasn't one of them! While I agree this isn't a bug exactly, it's definitely a userbility issue in my opinion. I tried a test, two nested shapes, repeat four times drawn as: 1:clockwise/clockwise 2:anti-clockwise/anticlockwise 3:clockwise/anti-clockwise, 4:anti-clockwise/clockwise. Case 1 & 2 did not 'cut-out' the interior as was desired. 3 & 4 both did, so the takeaway is to ensure in such cases that it doesn't matter which is outer or inner, just that the direction is not he same. While I have yet to import these test shapes into the CNC tool, I'm confident the results will be the same as was rendered when importing into an alternative app on the iPad as I did for this test. Thanks again, I'm glad the mystery is solved now.
  11. Hi - please take a look at this thread... Post in iPad questions The question was around export of a design to SVG where a curve is a shape compounded from two with the subtract operation. There seems to be a bug here given it's not just me experiencing it. Thanks!
  12. Thanks MikeW for the offer, I managed to fix it in Illustrator in the end - so at least this project can now be cut. I'm more worried about next time, as access to Illustrator isn't always possible. How can you tell they're not a single curve - is that by looking at the SVG output? Oh, and no, the tool accepts SVG only.
  13. Nope. While some colour / fill combos have meaning if present, it'll accept anything and let me set the cut type on-tool. So, this isn't the problem here. Thanks though.
  14. OK, so I did that... and it worked!! But... wouldn't dividing the shape simply put it back as was originally when the two shapes were first drawn? So I did another quick test. I used the pencil tool to create two shapes, one within the perimeter of the other as it is for the letter 'o'. I then used subtract, which made one curve and exported it. In the other app applying a fill ignores the inner shape again. So next I used divide on the result of the previous subtract, re-subtracrted and exported. This should be the same as you have outlined, and given it just worked with the real 'o' you'd think it would work with this new test document too... but no. The other app still ignores the inner geometry. Something very weird is going on. If someone at Affinity is reading this.. I'm mystified...and quite happy to record a video of what I'm doing...
  15. How? I selected both and used the subtract tool to cut the centre out from the silhouette. And now the entity is a single thing in the layers view... Is there some other way? To add: in Designer, when applying a fill, it looks good. Thanks!
  16. The colour is incidental... I probably did that to make drawing the new shape over the old easier to see. On the topic of multiple shapes, the one unchecked is the older, and wasn't exported in the SVG. Thanks for looking though
  17. Hi - The attached Designer file was created on an iPad. The 'text' was drawn with the pencil tool using the rope stabiliser. I then exported the file as an SVG to a CNC tool. The problem is the 'islands' in the P, O, & D. The P and D are OK - when the CNC tool is told the 'letter' is a pocket cut it wants to cut the letter correctly. In the case of the 'O' however, the centre hole/island is ignored. The tool wants to cut the entire silhouette of the 'O'. I imported the SVG into another vector tool on the iPad and it sees things the same way as the CNC tool. Ditto in Illustrator. So the problem appears to be in Designer. I have redrawn the shape from scratch a couple of times hoping to kick it into proper behaviour. No dice. (Actually I did have the same problem initially with the D, but re-drawing that made the problem go away. I also redrew it using the pen tool instead of the pencil. Alas, the O remains stubborn after hours of playing around with this! To draw these, I first drew the outline, then the 'island' and then used the geometry subtract tool to cut out the hole. If anyone can offer any insight - that would be great, because at this point I'm tearing my hair out. Thanks! Bob ThePoshShed-3107-1.svg ThePoshShed3107-1.afdesign
  18. On a Mac. Viveza and Dfine work, Color Efex and Silver Efex get stuck on 'preparing image' :-/
  19. Title says it all really, the panel also has the colour management mode. It may be this panel only appears with images that have been HDR merged? Either way, it’s in the way, and I can’t get rid of it... help please!
×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.