Jump to content

REVesseyJr

Members
  • Content Count

    5
  • Joined

  • Last visited

About REVesseyJr

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Who else is tired of this? While I am mostly happy with the functionality of AP, I am very dissatisfied with the customer service and management. When I first purchased AP in early 2018 I could not use it because the RAW developer stopped working properly for several months. I spent days trying to figure it out as AP hung everyone out to dry - no notifications or explanations of the issue (forum posts were not answered or severely delayed). The amount of time I spent trying to figure it out could have paid for the Photoshoot price premium for years. If I were depending on AP for professional purposes I would have been out of luck with absolutely no support and no idea when I would be able to get it. If you need a dependable editor and customer support I would think carefully b4 investing in AP. The forum is the ONLY way to get help, there is no manual and the in program help is very weak. Note that AP in this thread led customers to believe that a DAM was in the cards in near future (but not likely b4 2017. The latest I heard AP is not sure they are going to release a DAM. AP customer management and support stinks, they are terrible at informing and supporting customers. All of this can make using AP inconvenient and time consuming which I personally feel more than offsets any savings you realize purchasing AF. AF needs to get more professional and support its customers better, if I find another editor before they do they will lose my business. There are a lot of VERY attractive options out there to replace AP ‐ Luminar 4, Topaz Softwae Studio 2, On1 Software, Capture 1. I have already tried experimenting with some of these editors and I encourage anyone reading this to do so as well, I am willing to bet you will be pleasantly surprised. I like AP software but I am tired of dealing with the inconveniences that come along with it. I need reliable software and support. BTW. The justification that there is no DAM because AP is both a developer and editor is a lame cop out. If anything being both editor and developer increases the need for customers to have a DAM and there is no excuse nor is it acceptable that customers have been communicating this need to AP for 4+ years, AP misled them about DAM development, and AP has completely ignored its customers for 4 years on this issue. It's time for AP to stop making commitments it has no intention of keeping!
  2. I am new to AP, just downloaded Windows version last week. I am running Windows 7 Professional. Until this evening I was able to open, adjust, and develop RAW files just fine. Suddenly tonight this issue started: I open and adjust RAW files the the colors display accurately but when I develop the RAW image it turns gray and the colors change and are less vibrant. It appears to be more than an exposure issue because when I adjust exposure in the Photo Persona the colors are different. Very frustrating, has anybody encountered this issue? If somebody could offer a solution it would be greatly appreciated. Before and after screen shots appear below. I am puzzled. As I said everything worked just fine until tonight. I've already updated my monitor drivers and reset all settings to default (holding Cntrl key on startup, neither solved the problem. Before Development: After Development
  3. I am having the same issue I believe. I am new to AP, just downloaded it last week. Until this evening I was able to open, adjust, and develop RAW files just fine. Suddenly tonight this issue started: I open and adjust RAW files the the colors display accurately but when I develop the RAW image it turns gray and the colors turn change and are less vibrant. It appears to be more than an exposure issue because when adjust exposure in the Photo Persona the colors are different. Very frustrating, has anybody encountered? If somebody could offer a solution it would be greatly appreciated. Before and after screen shots appear below: Before Development After Developement
  4. I just plugged in a new keyboard into my Windows desktop machine and the shortcut keys don't work properly. The basic shortcuts - ie. Cntrl+O - seem to work but if I try to use the tools shortcuts they don't work unless I press Ctrl + (shortcut key) repeatedly. I also noted they work if I press the Spacebar + (shortcut key). I tried reverting back to the original keyboard which worked fine when I installed Affinity Photo and now it's exhibiting the same behavior. I'm thinking it's a Windows issue, I've looked at the keyboard settings and looked into drivers but have not come up with anything to solve the problem. Has anybody encountered this or can can anybody help?
×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.