Jump to content

philipt18

Members
  • Content count

    33
  • Joined

  • Last visited

Everything posted by philipt18

  1. I have an Affinity Designer file which is simply colored text, which is a logo for a company. I embedded that file into another Designer file which is for a business card. I clicked on the embedded file to adjust the color, and when I try to adjust the color of embedded text, it crashes Designer. I've done it twice in a row, and the same thing happens.
  2. philipt18

    Crash when adjusting text color in embedded file

    I've uploaded a sample file and a crash log (which has full specs on my Mac - but in short a 2018 2.9 i9 MBP with 560X graphics running 10.14.1). To be even more specific on how to get it to crash, you click through to the embedded graphic, then select it, click on the color in the inspector, and then you need to click into the color selector and then drag. It doesn't crash until you try to change the color by dragging.
  3. philipt18

    Crash when adjusting text color in embedded file

    To be more specific, it crashes when I click into the color selector, but not if I adjust the sliders.
  4. I have a series of master pages, that are the same except they have different background images. The thing that is the same is the location of the page numbers, which are two text objects grouped together. However, if I copy the group, or the layer itself, and paste it into a different master page, the text objects move to the middle of the spread. How do I get it to stay in the same place? It seems odd that if I copy a layer that it would change the location of the text objects in it when moved to a spread of exactly the same size.
  5. Interesting, I didn't realise you could apply multiple masters. I did think it made sense to be able to apply masters to other masters, but it doesn't seem that is possible. I'd still like a way to paste something in the same position it was in when copied. It seems a big omission that this isn't possible in a page layout program.
  6. He means you're leaving out half the world.
  7. I'm seeing some strange behavior, and not sure how to duplicate. I have a master page with 4 layers. The bottom two layers are currently hidden (a rectangle and a pixel layer), the next layer is a pixel layer, and the top layer is a text layer. I was adjusting the opacity of the visible pixel layer when I noticed that the slider wouldn't go away. I can click on the other layers and the slider is always functional, but it never goes away: Also, if I click on the Opacity percentage menu, it looks like this: This seems to be a bug...
  8. Definitely want this, especially a way to import flowing text, i.e. not just filling in business card templates, but filling in flowing text that formats each entry and then continues in a single text flow throughout the document. This could be used for building catalogs, directories, dictionaries, etc.
  9. I have a file I created in Affinity Photo that has a B&W white pixel illustration and some text, with a Recolor Adjustment layer that gives it a kind of Sepia tint (Hue 38.9, Sat 50%, Blend Mode: Color). I then dragged that image directly into an Affinity Designer file I was working on, and it showed up tinted. I was even able to adjust the color a bit as an 'embedded' file. When I export the Designer file to a PDF, however, the tint is missing.
  10. philipt18

    Exporting a Designer file with an embedded Photo file

    Interesting. It seems there is some tint in the final image, but because of the higher resolution and the fact that most of the image is black and white, the tint is barely noticeable. Previously I only used this image for the web, and the color showed quite clearly. When at the higher resolution for print the color fades away so much that it's not noticeable unless you zoom in really far and look for the bits of it. Not sure if this is a bug, but it is odd that exporting for web and exporting for print get some different results. dictionary-header-affinity-text.afphoto
  11. I'm running 1.6.1 and there still seems to be a problem here. I posted another bug report before finding this post, but I have a recolor adjustment that is not making it to export.
  12. philipt18

    Exporting a Designer file with an embedded Photo file

    I tried removing the recolor adjustment layer from the embedded file, and adding it as a sub-layer above the embedded file in the Designer file itself, but I got the same result.
  13. Any update on support for 1-bit B&W? This would be useful for lots of things.
  14. Is there an update on vector patterns? Is it available, or in the works? Thanks.
  15. Is there a way to apply a fill pattern along with a color? I'm printing something that only allows one color, so to differentiate something I wanted to fill the objects with a checkerboard pattern so it would show up differently. Is there a way to do this? Thanks.
  16. I'm a bit rusty with any design app, and I've never gotten completely up to speed with Designer. I'm trying to do something which I think is fairly simple, but I don't seem to be able to get it right. Simply, I have two shapes, and I want one to cut out of the other. Right now I have a group of shapes and I put it on top of the shape I want it to cut from, and I say to mask below, and it makes the bottom shape into the shape of the group above. What I want is in fact the bottom shape minus the group above (so it is transparent where the group was). How do I do this? Thank you.
  17. I figured this out. I selected the triangles and selected 'Expand Stroke' and then I subtracted them.
  18. Thank you all. I've been able to subtract one shape at a time, but I have a small problem. I have triangles that I want to subtract just the outline of, not the middle. The triangles have no fill, but subtract still removes the middle. Is there a way to get it to work without removing the middle? Thanks.
  19. I tried Subtract, but everything except Divide was grayed out.
  20. I have several font collections I've set up in Font Book and they show up properly in Affinity Designer. Whenever I select a specific smart font collection, it crashes Affinity Designer. This particular smart collection is based on language support only (for Hebrew). If I copy the fonts from that collection to a regular (dumb?) collection, it works fine. Simply clicking into the smart collection in the font selector crashes Designer.
  21. Come on, RTL support in Affinity products is something both those from Israel and the surrounding Arab countries can agree on. Think of it as contributing to world peace.
  22. Here's weird. I lowered the size of the exported image and the color was exported. That would seem to suggest there's a bug in exporting very large images.
  23. I have a B&W image that I've added a recolor adjustment to, that gives it a kind of sepia look. I've exported it in the past, but for some reason when I try to export it now it lacks the color that is supposed to be added by the recolor adjustment. If shows up in Affinty Photo, but when I open the exported image, it's B&W. Any idea why this is happening? To be clear, the recolor adjustment layer is visible and in the export persona, is 'visible in export'.
×