Jump to content

Adalbertus

Members
  • Content Count

    15
  • Joined

  • Last visited

Posts posted by Adalbertus


  1. As the new project for training and as just fun, I plan to recreate in Affinity Designer some objects or characters from cartoons or comic books from my childhood.
    Nothing specially serious. It doesn't have to be perfect and I also allow myself to do some minor changes in original designs.

    First project being created after hours of my regular job is coming from Disney's cartoon Tale Spin - it's seaplane "Seaduck" which was used by great pilot Balloo.

    Project isn't finished yet, but I've decided to share it.

    I know that shadows, details and some other things could be better, but for now it's just concept of the overall idea, and for sure will be still improved in spare time ;)

    seaduck2.thumb.jpg.2e1a81eab27d0fbddfdb94a9c3112f69.jpg

    seaduck.thumb.jpg.bcd2ab38fcb43c0b4b918c9a9e32c1fe.jpg

    seaduck_cr1.jpg.306fab5fac791bb67ea370f130fb182a.jpg

    seaduck_cr3.thumb.jpg.ee6aa3969ce0c47252afa3cef9daed94.jpg

    seaduck_cr2.jpg


  2. I don't see any answer after such time... It's really... quite sad...

    Today I have encountered the same problem as fadings.
    Some time ago I have seen these prestes and used them without any problem.
    Toady I've tried to map a 7MB file when app has frozen. By few seconds i 've seen loading presets. After that, app has shut down itself without any message.

    After manual relaunch, presets are gone. Import = crash. Creating new group = crash.

    Reseting the tone mapping presets during the launch - with pressed the CTRL button - without succes.

    System: Windows 7 on Intel Xeon E5450 with GeForce GT 730 and 8 GB of RAM. Until now I hadn't any problems with Affinity apps.

    My PC spec maybe is a bit old, but as we can see in fadings message, new specs are also in the bug range.

    Any ideas?

    By the way - maybe it's good time to move this thread into the BUGS section?


  3. 24 minutes ago, HVDB Photography said:

    Here is a download link of a set of macros for inside or outside borders with variable width and colour choice to use with a flattened image/ document

    https://forum.affinity.serif.com/applications/core/interface/file/attachment.php?id=76754

    Just test it out ...

    See attachment for the actions I took to add the outside border.
     

    Outside border.jpg

    Works well. Thanks for a macro and for the clear description! It seems that Affinity macros are really neat! Just need to spend more time with them ;)


  4. 2 hours ago, firstdefence said:

    You could kind of do it in reverse and unclip to content.

    Basically this creates a rectangle, moves it to the back, increases the dimensions of it by 80px horizontally and width wise from the centre and unclips it to show the border, this can then be coloured or a pattern added for a funktastic effect lol! In the macro you can adjust the width to suit.

    Variable Border.afmacro

    Screen-Shot-2019-03-25-at-11-49-52.png

    Thanks for your effort, but it seems, that You have created this macro on a Mac version, right?
    Our test result of Your macro You can see on the attached screenshot - something went wrong, and OS incompatibility may be the reason.
    But in spare time we'll try to repair this.

    test.thumb.jpg.b2395c1bf73337930ae1e7db9c658aea.jpg


  5. 2 hours ago, firstdefence said:

    Add a Fill Layer: Layer > New Fill layer and change it to whatever colour you like Aldabertus :D

    Ok, word of explanation ;)
    Yes, I know that I can use that, and Pixel layer as well.
    It just had to be a quick test macro - mostly to check all ways to do that task ;)
    Disabling the transparent background instead of playing with layers, had just one goal - to be a fast option in the search the way for the proper canvas resizing.
    My main question was:

    Quote

    I have created a macro with using FX Outline option - maybe there are better ways to do it?

     The Outline was for me the simplest way to configure it in Macro tool.

    And by the way.... I was just curious, did the white background colour, which is showed after disabling the Transparent background function, is hidden somewhere or did it depends on some other tool.

    1 hour ago, John Rostron said:

    I'm not sure what you are after, but I just tried this:

    1. I created a blank canvas with a white fill layer.
    2. Added some content to this canvas with limits away from the edges.
    3. Flatten the document. 
    4. Flood-fill the outer white area and delete it.
    5. Clip to Canvas.

    This removes the edges leaving the added content. 

    John

    Yes, John, Your approach is good, when You have time to do such operations.
    Our main goal is to do it fast as possible.
    We don't know what canvas will be needed - it would require calculations based on the image size and more precision to achieve desired effect.

    Simply, our goal is:
    Load some photo (there may be regular graphics/photos with solid background, or there may be some png files with transparency.)
    Edit it if needed.
    Crop to content.
    Add border along with the fill - both have to be in same colour.
    Export.
    Next image...

    I have created other macro, more complex (but still basic) and allowing to further work with the project.
    Still using the Outline FX.

    If we have prepared, cropped to content image, we can play the macro:

    1. Enable the Outline FX effect - to be able to resize canvas according to pixel value of this tool by using clip canvas option.
    2. Set radius to some pixel value... and this still it's strange, because it must be 39px to get proper width of 880px for bordered image from 800px image. 40px is resulting in 882px image. Why is that?
    3. Set FX Outline colour to any colour.
    4. Add pixel layer.
    5. Clip Canvas.
    6. Fill the pixel layer with any colour.
    7. Move the pixel layer below the product image.
    8. Select first layer with the photo of the product.
    9. Disable the FX Outline.

    Border_40px.afmacro


  6. We are often working with many various photos in a specific way.

    Often performed operation, after the whole process of photo editing is adding border.

    Let's say, that border have to be 40px at each direction for 800px image.

    I have created a macro with using FX Outline option - maybe there are better ways to do it?

    1. Change Document properties - uncheck the Transparent background in the Document menu.
    2. Enable the Outline FX effect.
    3. Set radius to some pixel value... and this it's strange, because it must be 39px to get proper width of 880px for bordered image from 800px image. 40px is resulting in 882px image. Why is that?
    4. Set FX Outline colour to white.
    5. Clip Canvas.

    Is there an option to change a default colour of the document background, or it must be white? White is good for us for now, but it's good to know ;)

    Next question is a little different, but also is close to our specific workflow with these photos.
    Is there a way to clip a photo as described below?

    1. We have a product photo with the white(or other), solid background.
    2. We choose some option to crop the image to content with ignoring pixels of the the background.
    3. Result is: Cropped solid background to the pixels of the product - It detects solid colour around the different pixels of the product accumulated at the middle of the document.

    For example, we have such option in Gimp: Image > Crop to Content.
     


  7. 8 minutes ago, mac_heibu said:

    Sure, jochenabitz! But do you know any professional designer, who doesn‘t use Acrobat or a similar app to control this? I don‘t.

    And for hobbyists it is really dispensable.

     

    5 minutes ago, mac_heibu said:

    Peter, I am a „professional designer“, believe me! And for a version one it is dispensable, because we have other tools for this. For a version one it would be a „nice to have“. That is, what I said and ment.

    I think that it's very good idea to create the whole independent environment for designing, including DTP preflight and control options. And now it's very good time to talk about it.


  8. I know that similar subjects were posted on this forum before in different places, but now when time to public beta of Publisher is near, I think it's good to remind this.

    To unleash the whole power of Affinity Range, we need proper pro printing tools, like good preflight,  good colour management, ink coverage measurement... Simply, all what is industry standard for this kind of work.
    I think that all these tools should be quite similiar (at least at some major points) to Adobe products.
    (For now, people designing for example in AD, must also use Adobe Acrobat Pro, pdfToolbox or other software if they want to print something at pro standard - and to avoid money loss because of wrong printing results)

    And a quick question, because I saw in some general topics, that such tools, maybe will be introduced in Publisher, and then maybe will be transferred in future to AD and maybe Photo too. But I wanted to create recent, separate topic for this, because this is quite important.
    So.... maybe my feature request is now ready in some shape (in APub?) or at least You can say something more about this? ;)
    I have seen video sneak previews for AD 1.7 and all features are awesome and I'm waiting for an update.
    Also I have of course seen APub short video preview but...it was short and there was nothing about printing features, but I think that this is very important for many of us here.
    To be honest, already I'm waiting with some shopping and other business decisions to see what you guys have prepared for us and I think that I'm not alone ;) And after AD and APhoto I believe in you guys.


  9. 6 hours ago, JACKJACK1234 said:

    Im having the same issue as Jimmini, When attempting to move the text parameters on a curve when holding the command button on a mac.

    goes to 100% CPU and AD becomes unresponsive. Ive tried in a different user and same issue again.

     

    Specs: Macbook Pro 2012, 2.3 GHz i7, 16GB RAM, NVIDIA GeForce GT 750M 2048 MB

     

    Makers Mark - Henry.afdesign

    It seems that Your file is very good AD killer ;)
    I've never yet had such problem with AD, but with Your file my copy of AD is unusable and unresponsive.

    My config is old a bit, but in most of the tasks is ok:
    Xeon E5450 3GHz
    8GB RAM (DDR2)
    GT 730 2 GB
    Windows 7 64bit


  10. Ok, I don't know why you have created this work in this way, because it's whole structure looks strange a bit ;)

    But this is not the main problem.
    Problem was that AD was showing You something else than in exported PDF and than in print, as You reported.

    I can't technically explain what is the reason, but I've made some tests.
    Rasterised exported files are ok - rather obvious, but...
    To achieve good exported file without rasterisation I've changed a bit structure of Your layers - see screenshot. It seems that problem is caused by elements making background (mask and rectangle) in Your lower group.

    Check the PDF file. I don't have Your font but this is not important.

    Can someone more experienced in technical details explain this whole case?

    ad_bug1.jpg

    4449_ticket_2017b.pdf


  11. Today I've worked few hours with few breaks (with AD active in background) on some document in A4 size.
    It has few embedded documents with logos (like 3x eps and 1x ai formats). Also there was 4 or 5 photos, few simple shapes with basic transforms (like skew and rotation) and text frames. No FX effects, no adjustments masks etc. Working on it was fast, without performance problems etc.

    I was saving this file regularly after every bigger step.
    And suddenly I've discovered that I can't save the file (Ctrl+S) and on the tab with file name I've seen Read Only status (anyway it's first time from beginning my work with Affinity).
    I thought ok, because just before I've saved file, so I close the file and load it again.
    On closing appeared message with saving file option (Save as). I've chosen that, and I've changed existing file - because not many changes was made, so nothing will happen even if they will be omitted.... That was what I've assumed.
    And after closing the AD I've realized by looking on the file image icon preview that in some way, my whole work is backed to the one of the first versions of that file...
    After loading it, I've got message about recovery file and yes I've recovered it, but as the file icon shown, it was very old file version.
    Windows (10) doesn't have in it's file recovery tool any version of that file so...
    Whole design work is gone now... forever.

    I can't provide now that file because it's private company's inside file, and now it's changed anyway. Maybe on staff priv only.

    Any ideas what could gone wrong?

    I've found similar topic but in Beta category:

    EDIT:
    In meanwhile I've recreated and finished the project, I've changed it much with using high quality photos, but worked on it without embedded files and so far so good. Maybe there is a problem, in managing embedded files?

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.