Jump to content
You must now use your email address to sign in [click for more info] ×

PMan

Members
  • Posts

    147
  • Joined

  • Last visited

Posts posted by PMan

  1. At first I'd missed the instruction 'hover over the erase blend mode' and had simply applied erase blend mode. No crash appeared then but when I tried to undo the action Publisher crashed.

    However  when I carried out the instruction to hover over the erase blend mode first the top 1/3rd of the picture partially disappears, then when the cursor is moved away without clicking,  the busy icon (hourglass) appears for a short time then the program crashes.

    Since this I have tried it with other pictures  since,and the erase function works perfectly, I can only assume that something within your art work is creating a conflict.  Maybe it's because you are trying to apply a blend mode to a group of layers (if you expand your group 'crash when erase' there are about 40 layers each named Curve; any of these can have the blend mode erase applied without any crash occurring or you can select a number of these layers together and then apply the erase blend mode without Publisher crashing). see attached file below

    erase blend mode.afpub

     

    The Help function on Blend Mode says
    "Any layer or object can have a blend mode assigned, including mask and adjustment layers. The default blend mode is 'Normal'—no special compositing is applied. For a group, the default is 'Passthrough'. When set, the group itself has no special blend properties of its own, and passes on the blend mode of its parent layer.

    I then found that if you select the group 'crash when erase' and apply 'passthrough' first then the problem you outlined

    1. Select the group named 'crash when erase'.
    2. Click on the blend mode drop down
    3. Scroll down and hover over the erase blend mode, but do not click.
    4. Move the mouse away from the erase blend mode and application crashes.

    does nor occur when you hover over erase blend then move away. It only occurs when the group 'crash when erase' has been set to blend mode Add (as in your file) and then you attempt to reset it to erase

     

    Pman 

     

    Asus Vivobook 15  Intel I7 processor,  Intel Iris X graphics, Windows 10 Home Version 20H2 (64 bit),  32GB RAM.  
    Affinity Designer 1.10.5.1342, Photo 1.10.5.1342, Publisher 1.10.5.1342 
    Affinity Designer Beta 1.10.5.1342, Photo Beta  1.10.5.1342, Publisher  Beta  1.10.5.1342
    Affinity Designer2 V2.1.1, Photo2 V2.1.1,  Publisher2 V2.1.1
    Affinity Designer2 Beta V2.2.0.1931, Photo Beta 2.2.0.1931, Publisher V2.2.0.1931

     

     

  2. downloaded your test file and it exported to PDF from both Publisher and Designer with no problem even when I placed a picture to almost fill it [resultant file 2156kb in size].  Exporting to jxl produced a file of 2845kb so I don't know what's causing your problem [jjonker and Hangman]

     

    Asus Vivobook 15  Intel I7 processor,  Intel Iris X graphics, Windows 10 Home Version 20H2 (64 bit),  32GB RAM.  
    Affinity Designer 10.5.1342, Photo 1.10.5.1342, Publisher 1.10.5.1342 
    Affinity Designer Beta 1.10.5.1342, Photo Beta  1.10.5.1342, Publisher  Beta  1.10.5.1342
    Affinity Designer2 2.0.4, Photo2 2.0.4,  Publisher2 2.0.4

     

      

  3. I can't replicate that. If I have several tabs open and I close the rightmost one, then focus simply changes to the tab which was previously the last but but one, exactly as I would expect. Have you tried re-installing Publisher 2?

     

    Pman

     

    Asus Vivobook 15  Intel I7 processor,  Intel Iris X graphics, Windows 10 Home Version 20H2 (64 bit),  32GB RAM.  
    Affinity Designer 10.5.1342, Photo 1.10.5.1342, Publisher 1.10.5.1342 
    Affinity Designer Beta 1.10.5.1342, Photo Beta  1.10.5.1342, Publisher  Beta  1.10.5.1342
    Affinity Designer2 2.0.0, Photo2 2.0.0,  Publisher2 2.0.0

  4. Hi I spent a little while trying to get Quick Grid to work. The help topic says Press the right/left arrow to add/remove columns and when I tried PRESSING the right key whilst drawing an object, it did NOT add a column.

    2099010546_AF2quickgrid.PNG.243171279a690fa26804bd14d5a4f063.PNG

    What I found instead is that if you TAP the right arrow  whilst drawing an object, that produces an extra column for every tap you make.

    Hope this helps prevent some headscratching when you try it out.  Now I've found the secret I look forward to drawing quick grids!

    Still finding my way around but generally loving Affinity2

    Pman

     

    Asus Vivobook 15  Intel I7 processor,  Intel Iris X graphics, Windows 10 Home Version 20H2 (64 bit),  32GB RAM.  
    Affinity Designer 10.5.1342, Photo 1.10.5.1342, Publisher 1.10.5.1342 
    Affinity Designer Beta 1.10.5.1342, Photo Beta  1.10.5.1342, Publisher  Beta  1.10.5.1342
    Affinity Designer2 2.0.0, Photo2 2.0.0,  Publisher2 2.0.0

     

  5.  

    Crashing on delete page or page1.

    I can't replicate problem [see below] though someone once had similar problem when they had applied multiple masters to different pages

     

    Pman 
    Asus Vivobook 15  Intel I7 processor,  Intel Iris X graphics, Windows 10 Home Version 20H2 (64 bit),  32GB RAM.  
    Affinity Designer 10.5.1342, Photo 1.10.5.1342, Publisher 1.10.5.1342 
    Affinity Designer Beta 1.10.5.1342, Photo Beta  1.10.5.1342, Publisher  Beta  1.10.5.1342

     

    Computer specs. Asus.txt

  6.  

    On 3/16/2022 at 10:16 PM, Wosven said:

    It's nice of you to try to help, you can test the file if you want: for example, just add a background color in a cell style and hit "OK":

    tests.afpub

    I needed the same style in the different files with the apps shortcuts, since I wanted to translate them in French. That's why there's this file with all the needed tables I simply needed to have the same style in the original files, anddo some modifications at some points.

    It keeps on crashing the 1.10.5.1282 beta version, but not the recent 1.105.1342 release available recently.

    As you note, it certainly isn't crashing on Publisher 1.10.5.1342 or Publisher Beta 1.10.5.1282 so tables should work fine for you now

  7. Hi Wosven,

      I have no trouble with changing formatting in a table or changing a format's name or applying new formats without any crashing. I've attached a publication, made using Publisher Beta, showing some table formatting examples and hopefully this might help you in some ways.  

     

     table formatting.afpubtable formatting.afpub

    If you still find your app is crashing then Serif would appreciate you providing a crash report see below post by moderator Leigh October 1st, 2019

    You may have been asked to provide a crash report when speaking with our support team. 
    This will help them look into your issue further and hopefully allow our developers to 
    figure out what caused the crash. Below are instructions explaining where the Crash Reports 
    are stored on Windows


    Press the Windows Key + R to launch the Run dialog and enter the relevant app path:

    %AppData%\Affinity\Designer\1.0\CrashReports\reports
    %AppData%\Affinity\Photo\1.0\CrashReports\reports
    %AppData%\Affinity\Publisher\1.0\CrashReports\reports
    Our crash reports will have a filename that's made up of random alphanumeric characters 
    and will have a .dmp extension. 

    If you can find that report and attach  it in your next post, it will be helpful to the Serif developers

    Another way is to go to C:\Users\yourusername\AppData\Roaming\Affinity\Publisher\1.0\CrashReports\reports

     

    Pman

    Asus Vivobook 15  Intel I7 processor,  Intel Iris X graphics, Windows 10 Home Version 20H2 (64 bit),  32GB RAM.  
    Affinity Designer 10.5.1342, Photo 1.10.5.1342, Publisher 1.10.5.1342 
    Affinity Designer Beta 1.10.5.1342, Photo Beta  1.10.5.1342, Publisher  Beta  1.10.2.1282 

     

     

     

  8. If you select the text, go to the paragraph tab and select Auto-hyphenation ON, the result will give you a better result

    image.png.560471ce40b470f874d2560137cfcf50.png

    With Auto-hyphenation OFF, Publisher has to try to fit the whole 'word' between backslashes onto a line [the word in this case can be quite long because individual words are being concatenated into long phrases by the underscore symbol _

  9. Ooops! 
    Yes I was accidentally in Preview Mode. Having turned it off, everything is working well so thank you Seneca for your  prompt reply and esp Joachim_L for noticing in video.  Hopefully it will be of use to others to note the behaviour of text frames when one is in Preview Mode!

     

    Pman

    Acer Aspire E51 AMD Radeon E1-7010 processor with AMD Radeon R2 Graphics, Windows 10 Home Version 20H2,  12GB RAM.  
    Affinity Designer 1.9.2.1035, Photo 1.9.2.1035, Publisher 1.9.2.1035 
    Affinity Designer Beta 1.10.0.1085, Photo Beta 1.10.0.1085, Publisher  Beta 1.10.0.1103

  10. Hi,

    I loaded Publisher Beta 1.10.0.1103 and wanted to check out possible crash when putting text into text frames assigned to Master pages.

    I selected Master pages and drew a text box on the left hand page, but as soon as I moved cursor to the right hand page and drew one there, the one on the left hand page became invisible. 
    Using the Move tool, you can select either box but the other becomes invisible.  You can link the two text boxes but the link becomes invisible

     

    Once I had managed to draw and link two text boxes, I then went to a double page in the publication, but again the text boxes were invisible.  However they are there and linked but I can only prove that by picking  the Move tool , selecting the empty text frame on the left page and inserting filler text.
    Also if I draw other text frames, only the last one drawn remains visible and links ,once made, become invisible

     

    Being unable to see text frames and links is making this Beta very difficult to use

    Pman

    Acer Aspire E51 AMD Radeon E1-7010 processor with AMD Radeon R2 Graphics, Windows 10 Home Version 20H2,  12GB RAM.  
    Affinity Designer 1.9.2.1035, Photo 1.9.2.1035, Publisher 1.9.2.1035 
    Affinity Designer Beta 1.10.0.1085, Photo Beta 1.10.0.1085, Publisher  Beta 1.10.0.1103

     

     

     

     

  11. Today I wanted to find a keyboard shortcut so I opened Help, typed 'shortcuts'.  From the topics listed

    image.png.41f930ee2a27e4d0b60b4116c17a514f.png

    I chose Keyboard shortcuts and this page opens. 

     

    image.png.7684d0af006540cd4d340fef31489f87.png 

    Although it is possible to change from All categories to any of the other 11 categories, nothing shows up on the screen.

    Am I missing something? [The same happens in Publisher Beta too!]

    Pman

    Acer Aspire E51 AMD Radeon E1-7010 processor with AMD Radeon R2 Graphics, Windows 10 Home Version 20H2,  12GB RAM.  
    Affinity Designer 1.9.2.1035, Photo 1.9.2.1035, Publisher 1.9.2.1035 
    Affinity Designer Beta 1.10.0.1085, Photo Beta 1.10.0.1085, Publisher  Beta 1.10.0.1098

  12. 1) It would seem that they are treated as characters because when text and emojis are selected and character size is altered the emojis also are altered.

    2) Although preflight says that i) the emojis create a spelling error and
                                                       ii) the characters are missing,
    the resultant pdf file displays them correctly. 

    Now that preflight issue may  be something Serif will  need to address.

    image.png.1324b940ae3e4ec82eb065a98761aeef.png

  13.  

    Hello uneMule and everyone

    Hopefully this may help clarify for others why it is normal.

     

    Indent values.afpub  and a video to explain it as it happens

    Bonjour uneMule et à tous

    Espérons que cela puisse aider à clarifier pour les autres pourquoi c'est normal.

     

    Acer Aspire E51 AMD Radeon E1-7010 processor with AMD Radeon R2 Graphics, Windows 10 Home Version 20H2,  12GB RAM.  
    Affinity Designer 1.9.2.1035, Photo 1.9.2.1035, Publisher 1.9.2.1035 
    Affinity Designer Beta 1.10.0.1085, Photo Beta 1.10.0.1085, Publisher  Beta 1.10.0.1098

  14. I can't reproduce it  [Publisher  Beta 1.10.0.1098] because I find that I cannot Shift + Click on the linking icon on page 1.  If I try that, nothing happens.  I can only link frames by simply clicking on the link icon on page 1 and then move cursor to the next text frame [on page 2].  
    If I link fame on page 1 to frame on page 2 first and then insert filler text in frame on page 1, then all three frames [pages 1, 2 and 3] all fill without any crash.

    A further point. 
    i) If text frames are put onto the Master pages and linked, there is no automatic link made between a right hand page and the following left hand page. Thus there is no link between page 1 and page 2  which is why I have to manually link page 1 to page 2
    and
    ii) if you insert another page after an odd numbered (right hand page), there is no link between that odd numbered  and the next page but I find that by inserting the missing link by clicking on the linking icon on the right hand page and selecting the following text frame (on the next left hand page), then the text flow works .

    autoflow text frames.afpub

     

     

    Acer Aspire E51 AMD Radeon E1-7010 processor with AMD Radeon R2 Graphics, Windows 10 Home Version 20H2,  12GB RAM.  
    Affinity Designer 1.9.2.1035, Photo 1.9.2.1035, Publisher 1.9.2.1035 
    Affinity Designer Beta 1.10.0.1085, Photo Beta 1.10.0.1085, Publisher  Beta 1.10.0.1098

  15. Bonjour uneMule,  je ne parle pas la francais!

    Watching your video shows that when you alter the top value, the lower one also alters, but when you change the lower one the top one does NOT.  This is to be expected as the top value alters the indent for the WHOLE paragraph whilst the lower one alters only the indent for the FIRST line.  This is best shown when your paragraph has more than ONE character (see my video).   Hope that his has helped you. 

    Au revoir

     

  16. Hi Walt,

    image.png.d67766077e07c8187679a816d117ee1d.png

    Definitely works in Beta 1.10.0.1085.  I then tried this in Publisher 1.9.2.1035 but it didn't work in that

     

    Acer Aspire E51 AMD Radeon E1-7010 processor with AMD Radeon R2 Graphics, Windows 10 Home Version 20H2,  12GB RAM.  
    Affinity Designer 1.9.2.1035, Photo 1.9.2.1035, Publisher 1.9.2.1035 
    Affinity Designer Beta 1.10.0.1085, Photo Beta 1.10.0.1085, Publisher  Beta 1.10.0.1085

  17. Congrats to Serif for once again producing updates.  Have just downloaded Publisher beta 1.10.0.1085 and just to save others trying out , the problem of selection of rasterized objects is still present in this Beta. Not surprising since the problem was logged AFTER the new download was available, but I'm sure development team will be working on a solution. As I noted earlier, the workaround is to select the object from the Layers tab and not by using the Move tool.

     

    Acer Aspire E51 AMD Radeon E1-7010 processor with AMD Radeon R2 Graphics, Windows 10 Home Version 20H2,  12GB RAM.  
    Affinity Designer 1.9.2, Photo 1.9.2, Publisher 1.9.2 
    Affinity Designer Beta 1.10.0.1085, Photo Beta 1.10.0.1085, Publisher  Beta 1.10.0.1085

  18. I can't find a way to rasterize a layer in Publisher Beta persona. I can select an object in a layer, right click on it and rasterize the object, but right-clicking on a layer gives no option to rasterize the layer and the option in the Layers menu is greyed out too.  There is also nothing in the Help file to tell me how to rasterize a layer, (although I can rasterize  a layer by going into Photo persona, rasterizing the layer and then returning to Publisher persona).

    However, I  find that if you rasterize an object on a layer, and try to select the object using the Move tool, then the object cannot be selected unless I first select (activate) the layer that the object is in using the Layers tab.  Secondly if I rasterize several objects on a single layer, then to select an object I have to first activate the layer by selecting it in the Layers tab then click on it with Move tool. 
    The selection of each rasterized object in turn on a single layer has to be preceded by selecting the layer first and then the required object, (although you can simply select each object in turn from the Layers menu without using the Move tool to select)

     

    Acer Aspire E51 AMD Radeon E1-7010 processor with AMD Radeon R2 Graphics, Windows 10 Home Version 20H2,  12GB RAM.  
    Affinity Designer 1.9.2, Photo 1.9.2, Publisher 1.9.2 
    Affinity Designer Beta 1.9.4.1065, Photo Beta 1.9.4.1079, Publisher  Beta 1.9.4.1082

  19. nto,

    I know you've said earlier that you know the rules of forum but one reason you may not be getting the help you ask for is because your problem is not listed as a new topic.  For instance your problem listed above is shown as a reply to the announcement about Publisher 1.9.2.1024 so it is not evident that you have a problem unless someone just wanted to see what you had commented onimage.png.db8b0fd89f5459c71db4cfc26213d8b5.png

    Instead what you should do is open the page Report a Bug in Publisher Beta and then click on  the Start new topic button [shown above]  You could then give your topic a title image.png.be185b7c150fb76aac4225f215234b8c.png eg Tables Not Working Correctly

    and then describe your problem as per the page Report  a Bug in Affinity Publisher.  People will then see your topic and know it is reporting a bug and not simply a reply to another topic.  You will probably find that 
    a) Serif will locate your problem much more quickly and either suggest a solution or log it to their development team       and
    b) other experienced users may well suggest solutions which they have found to work.

    Hope this leads to solutions for you

    Pman

    Acer Aspire E51 AMD Radeon E1-7010 processor with AMD Radeon R2 Graphics, Windows 10 Home Version 20H2,  12GB RAM.  
    Affinity Designer 1.9.1, Photo 1.9.1, Publisher 1.9.1 Affinity Designer Beta 1.9.2.1005,  
    Photo Beta 1.9.2.1005, Publisher  Beta 1.9.2.1024

     

     

  20. I can only say that my numeric keypad (once enabled by pressing Num Lock key) allows me to enter decimal points in the transform panel as Pauls noted (my laptop keyboard, even when the separator is set to  or (in Control Panel - Clock and Region - Region- Additional Settings - Decimal Symbol)

    Pman

    Acer Aspire E51 AMD Radeon E1-7010 processor with AMD Radeon R2 Graphics, Windows 10 Home Version 20H2,  12GB RAM.  
    Affinity Designer 1.9.1, Photo 1.9.1, Publisher 1.9.1 Affinity Designer Beta 1.9.2.1005,  
    Photo Beta 1.9.2.1005, Publisher  Beta 1.9.2.1014

×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.