Jump to content

dolunaykiz

Members
  • Content Count

    49
  • Joined

  • Last visited

Everything posted by dolunaykiz

  1. I created a macro to replicate what CTRL+SHIFT+J would do in Photoshop. That is, it is supposed to duplicate the first layer, fill that original one with white, then duplicate copy again. What I should end up with is a white bottom layer and then two identical layers with the actual picture content on top of it. Because all filters in Affinity Photo are destructive, this saves me the time to duplicate the original layer manually. And it worked until yesterday. Now, when I run the macro, it keeps the original layer and fills the other two with white. This only happens on some images, and there is no rhyme or reason why.
  2. Thanks for the input. None of the Nik Collection should crash anything IMHO. We've already been through it.
  3. Nik Collection just prompted me to install an upgrade to version 2.3.0.0. I am on Affinity Photo 1.7.3 and I want to avoid another disaster like what we experienced about a year ago with Nik just bombing on Affinity Photo. That was only changed when the finger pointing and shoulder shrugging caused a user community sh*t storm. However, I don't have time for the same thing this time around. Can anybody tell me if this is compatible BEFORE I install the upgrade, please? If it is not compatible, when can we expect it to be? Thanks. PS. I am on Mac OS Catalina.
  4. DxO, first paid version. Right now I don't have the funds to buy the 2.0, and frankly, I shouldn't need to.
  5. Update: it just started happening again. I've been processing a few photos in a row, and the preview comes up blank. I mean, WHAT?
  6. I am using Affinity Photo, latest version, on a Mac. As unsatisfactory as things have been, the latest fix seemed to make Nik usable again on Affinity. Until just now, when all of a sudden - and mind you, nothing had changed in my setup from one moment to the next, other than me opening another file - Color Efex and Silver Efex came up with basically empty previews. As in, you see just a B&W raster screen, that is it. I mean, can we make this a stable thing here, people? When it crapped up last time, we got some BS about how Photo wasn't meant to support PS plugins (which is why there's a plugins folder etc.?!?!), and I understand we can't just wave a magic wand over some things. But I mean, COME ON, PEOPLE!!!
  7. OMG, this has got to be the stupidest thing. When you copy adjustment layers from another document, unlike photoshop the layer is the dimension of that first document. It doesn't adjust to where it's dragged, no matter what you fill it with. That should DEFINITELY be fixed. Jeezes.
  8. I know how to use layer masks. I know what to do w/ them. It seems that Affinity Photo doesn't. If I paint w/ black on a layer mask I expect the photo to show a result in the viewer, but it doesn't. Or it only does on parts of it and on the others it's as I'd never painted on them.
  9. and BTW, i just experienced the same thing again. this time on an adjustment layer with only one mask. i could paint on one side of the mask and it would register, but not on the other. this is not normal behavior.
  10. I'm currently on the Beta version of Photo owing to the Nik Filter issues this resolves. However, the issue I am seeing should have nothing to do with that, it occurs on both versions. I recorded a macro when I first got on Affinity Photo which selects the background layer, duplicates it, fills the original layer with white, and as a last step renames the copied layer "Layer 1". All of a sudden every once in a while, the only thing I get is a blank layer filled with black on top of the background layer called "Layer 1". It's hit and miss. Sometimes it works, sometimes it doesn't.
  11. I should have phrased it better. The issue occurred when I put a mask on an actual layer and painted on it. Nothing happened.
  12. It's like, you paint on the mask, and nothing happens. I mean, WTH?
  13. This is a bug regarding adjustment layers. So I have a picture open and I make a brightness adjustment. Apart from the fact that the layer mask isn't automatically added to the adjustment layer, like in PS - but I can live w/ that - when I do make adjustments, they are not reflected in the file. Like I paint on the layer mask I just manually added in black or white, and it's like I never did anything. This isn't just an issue w/ the new beta, it's been an issue. Is this a memory problem? What is going on here?
  14. They told me Nik Collection 1 (2018), which is what just bombed.
  15. They should have provided you with an upgrade option? I'd contact DxO. On a lighter note, those plugins used to be $150 EACH...
  16. That would be very much appreciated.
  17. That is just it. This worked OK last week, then automatic updates are applied, and "poof". I don't have the $$ to pay for Nik 2, either. And frankly, I shouldn't have. I am not sure if they do ANY testing before they roll these out? And then the claim that b/c you got this from the AppStore, too bad for you? AFAIC the "right" thing to do here is to apply a bug fix so that Nik, whatever the version, or for that matter other plugins are usable. DxO plugins instantly crash the software. If you're building an app like this, wouldn't you be thinking about stuff like that as you develop it?
  18. I am on a Mac. And if you now try to tell me that too bad, it's not possible because that's how I got it, we all know these are files in the end, and if you have them for Windows, you can make one available for Mac. I want to like this software, but you're not making it exactly easy.
  19. Well, then give me an option to roll it back. And it would have been nice to know before the update.
  20. I am using Nik 2018 v.1.2.18 and Affinity Photo 1.7.
  21. I've waited for decades for somebody to take on Adobe's monopoly. I am not expecting Photoshop. I expect a program I can actually work with, not something where a bug is fixed here and then something else breaks.
  22. Oh, the Nik plugin works actually, but you get the "Updating fonts" loop as soon as you invoke it, and it prevents you from saving any changes.
  23. With the recent update making Nik crash, I think you should find one, because right now Photo is pretty much unusable.
  24. You do realize what you're saying here, right? If you didn't want to be an alternative to Adobe's overpriced products with a similar functionality, why do this at all? You must have known that professionals switching to you would expect their plugins to work, or at least not crash like this. I'd recommend y'all go back to the drawing board and decide what business you want to be in. In the meantime, please make it possible to roll back from the 1.7 update to Photo so I can go back to editing pictures. Please and thank you.
×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.