Jump to content

Tim Gummer

Members
  • Content Count

    83
  • Joined

  • Last visited

Posts posted by Tim Gummer

  1. I there anywhere a master list of  plugins which work with affinity?
    Even an unofficial one?

    I already have Designer and Photo, still mainly using photoshop for image editing and would love to minimise that

    I  want to invest in broadening my filter toolset a bit but focus on plugins which are known to work - even partially, with affinity.

    Any clues on this will be appreciated. 

     

  2. If i copy text - either as a block OR within the block as text - and try to paste it to another app - i get nothing.

     

    This is very frustrating as sometimes i creat copy for say a flyer .. in the app, and then i can't reuse it.

     

    Also kind of unbelievable. Copying between apps was one of the Mac's claims to fame, back with it came out  in the eighties. 

     

    Note i do have Alfred 2.0  running with multiple clipboard pastes - works for everything else.

     

     

  3. No this is not an alt/option drag - i do that intentionally a lot but in these cases i don't have the modifier down - given how common this issue is i'm really careful to avoid that but it still keeps happening, (when i say 'keeps' i mean randomly).

     

    TIM

     

    [Sorry to be late back on this - not getting notifications on replies] 

  4. I'm having a resurgence of a historic issue that i thought had largely gone away. 

     

    Affinity is creating extra copies - sometimes 3 or 4 of them, overlaying the existing ones.  I still don't know what triggers this as i only find them later., though it may be to do with subtle drag motions (without a modifier).

     

     This is EXTREMELY ANNOYING.  I remember posting on it previously but can't find it sorry.  But I'm sure I'm not the only one suffering from this

  5. Just a little thing really but  - currently, as soon as artboards are cloned they appear in the layers panel under the same name, and it's difficult to know which is which without clicking around the place. Of course they will eventually get proper names, but it would be lovely if they just named themselves Artboard 1, Artboard 2 etc when cloned.

     

    That is all. 

  6. It seems that control-enter is actually…

     

    the soft return key combo.

     

    At the point of this posting after eons of frustration using the usual shift-return I only just thought to try some wild and crazy key combos, and stumbled on control-enter.

     

    Dearest AD peeps…

     

    Why?

     

    Why Why Why… not a normal, intuitive, standard key combination for this?

     

    But at least now I have something that is better than my workaround: quite literally that was breaking text boxes into two and nudging them vertically… such was my desperation with the line height issues I was getting via shift-return.

  7. I'm always big on batch processing and an efficient export workflow.  I've spent quite a bit of time trying to get the most out of AD 1.5 exporting - but i'm still mystified at what Batch Builder actually does.

     

    No help on it.  No google returns outside of the feature list saying: Batch Builder for multi-slice imagesets (Xcode asset JSON)

     

     

    And it seems to be very oriented around touch icons - is there scope for more?

     

     

    Please affinity, let us in on the secret?

     

  8. Thanks rsi.studio - cmd j and then constrain is a decent workaround WHILE THIS FINALLY GETS FIXED.

     

    i'm still cleaning up gunked up files - with LOTs of  10x clones.

     

    For the devs - I have noticed this appears to happen sometimes if the rendering is slow and I'm just moving elements.

     

    Its a very circular issue cos the rendering is sometimes slow because of hundreds of unwanted clones.

     

    But if for whatever reason… sometimes the rendering is v slow, cloning can occur.  IN my case I think it's mostly the main bug, but somtimes a move that renders very slow - will create a clone.

  9. Truth is - that I just can't find any pattern.  Sorry to be so late following up but I have been looking for cause > effect and not finding colleration!  So no single reproducable set of steps to recreate this issue - though its very common for me, and as i understand also happens for others.  

     

    The only common element is it tends to be in relatively complex layups with a lot of layers generally.  I don't believe I'm inadvertantly applying modifier keys - I do use shift quote a bit to constrain  / unconstrain.  I use option a lot when i'm intentionally cloning.  that's it.

     

    But it really does drive me crazy: I'll be about to output a pdf and see badly aliased text - then find that's because it's cloned 3-4 times, then the filled curve behind is cloned a dozen times.  This is No way to work and it's plaguing my most important projects.

     

    What to do next?

  10. I'm working in a Sketch shop and have to supply sketch files as deliverables - or at least for archive purposes.

     

    Copy/Paste from AD appears true visually so that's great.

     

    problem is that my careful organisation and labelling of elements in AD is lost.

     

    Given that Affinity is making a big play for UI use in 1.5, I think tidying up this part of the realworld workflow that many of us in this area have to deal with, is essential.

     

    Sketch has such a grip on this area, we need to be able to deliver editable files that are organized ande make sense to Sketch users.  Obviously it's impractical to relabel everything on export, then do it again (once would be beyond practical) on the next export.

     

    Hoping this isn't a big ask - given the structure is there already - its just the labelling that's getting lost (I think) 

     

  11. AD is always very 'generous' in creating extra elements when I never asked for them.  


     


    This is without option dragging or duplicating as a command.


     


    Result is I go to move something there are 3 copies underneath. Or because of the same... apparent transparency get's thickened up when i don't want.


     


     


    I've been getting this since the earliest version (I'm an early AD adopter), just put up with it but now we're 1.5 - really this shouldn't be happening


     


    Can this be fixed soon please, or is there something I may be doing to create it?


     


     


    (Running on El Capitan.)


     

     

    PS: I've heard there are other posts on this in bug but I haven't been able to find them

  12. AD is always very 'generous' in creating extra elements when I never asked for them.  

     

    This is without option dragging or duplicating as a command.

     

    Result is I go to move something there are 3 copies underneath. Or because of the same... apparent transparency get's thickened up when i don't want.

     

     

    I've been getting this since the earliest version (I'm an early AD adopter), just put up with it but now we're 1.5 - really this shouldn't be happening

     

     

    Not sure where bugs get posted, can't believe others haven't had this issue. Can this be fixed soon please, or is there something I may be doing to create it?

     

     

    (Running on El Capitan.)

  13. I hit a bug with IE9-11 browsers which need their svg backgrounds to have elements with explicit dimensions

     

    EG:

     

    <?xml version="1.0" encoding="UTF-8" standalone="no"?><!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd"><svgwidth="1446px" height="1397px" viewBox="0 0 2600 1397"

     

     

    rather than

     

    <?xml version="1.0" encoding="UTF-8" standalone="no"?><!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd"><svgwidth="100%" height="100%" viewBox="0 0 2600 1397"

     

    which it currently produces.

     

    Is there a way to do this currently, or could that be added in soon?

     

    IT's a real headache to have to hand code a whole bunch of (multi breakpoint) output files, after every slice output   - eg on this project there's about 16 to do each time.

     

     

     

    FYI  the source on the IE bug is at here on stackexchange.

     

    Thanks!

  14. I've come to understand slicing AD better but i'm still enormously frustrated, relative to how I used to work in Fireworks (apart from it's bugginess).

     

    1. scaling/moving  artwork objects under slices (in export persona)
    2. opt-drag cloning slices
    3. 8bit png alpha tranparency

     

    scaling/moving  artwork objects under slices (in export persto use ona)

    My main problem is that AD presumes I will scale slices relative to layers.  Actually frequently I need to scale layers (objects) to confirm with slices.  IE the slices provide a visual grid that i need to confirm to.

     

    To achieve this now I either load up countless guides, or (and this is true, i really do this)  - I take a snapshot of the export persona and paste it in as a guide within the draw persona.

     

    The way Fireworks behaved, or at least was meant to behave (god that thing was buggy), was far far better.

     

     

     

    opt-drag cloning slices

     

    8bit png alpha tranparency

     

    ...These latter two being self explanatory

     

     

    Am I missing anything here?

     

     

    TIM

     

     

    Note previous queries about non-intuitive slices UI at https://forum.affinity.serif.com/index.php?/topic/9881-slices-and-export/

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.